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Perface
We live in technology-driven world, where almost everything is automated. The fast two decades
¼n’kd½ have  seen a renaissance ¼iqu:RFkku½ in the world of innovations. We have seen docotors per-
form surgery by sitting miles away from their patients. The fashion industry is soon to replaces
supermodels with robots (one such, the Sophia, was developed by Hong Kong based company
Hansaon Robotics). There are similar advances being made in every field, all of whose foundations
are based on Computers.
It can often be perplexing ¼gSjku djusokyk½  for a beginner to keep pace with such developments. To
be lost in the world of codes and bytes can be nerve-racking. And this is where a text book of this
nature comes in. Written assuming absolutely no prior knowledge of Computers, this book car-
ries the students through the world of financial skills on Computer in a simple and structured
manner.
What this book does aim to achieve is to give you an eye opener, a mild introduction of Application
Software MS-Excel. It will teach you the basic and advanced building block of MS-Excel, and also
cover the formatting and editing your documents in attractive manner which is necessary in all
offices all over india. It also gives an introduction to various useful commands which helps you to
create financial reports online and offline.
This book of MS-Excel covers all the useful commands of latest version of MS-Office.
There indeed are several books that flood local book shops on this subject. So why should you use
this one? The answer is simple; We have not written this book keeping a specific audience in
mind. Whether you are a school student, a budding engineer pursuing technical education, or
want to be master of document creation then this book will be appropriate search for you. We
have kept the language at a level that can be accessed by one and all, and yet kept the discussions
thorough and focused.
More specifically, it can be used by the following:
Students pursuing CCC, DCA, DFA, ADCA, PGDCA, CTTC, DDEO etc. Courses from our Branches.
Student pursuing short - term courses in our Authorised Branches in all over india.
Finally, this book is for everyone who is either excited about computers or interested in knowing
more about computers.
This book is impregnated with several salient features:
A completed self-study material obtaining basic and advanced knowledge of spreadsheet.
Covers Microsoft Office suites Software.
Concepts and Lab idea are explained using ample number of illustration and screen shots for
visualisation of the commands.
Hope that the book will be very useful and move on right path of one’s career.
We regard the suggestion and options of the users as most effective guideline for improving this
book further.
warm regards
Richson Technoserv opc (P) Ltd.
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Getting Started with Excel Chapter 1
Introduction
MS-Excel 2013 is a spreadsheet program that allows you to store, organize, and analyze information. While you
may believe Excel is only used by certain people to process complicated data, anyone can learn how to take
advantage of the program's powerful features. Whether you are keeping a budget, organizing a training log, or
creating an invoice, Excel makes it easy to work with different types of data.
Getting to know Excel 2013
MS-Excel 2013 is similar to Excel 2010. If you have previously used Excel 2010,  Excel 2013 should feel famil-
iar. If you are new to Excel or have more experience with older versions, you should first take some time to
become familiar with the Excel 2013 interface.
The Excel interface
When you open Excel 2013 for the first time, the Excel Start Screen will appear. From here, you will be able to
create a new workbook, choose a template, and access your recently edited workbooks.
From the Excel Start Screen, locate and select Blank workbook to access the Excel interface.

This is welcome screen as you open first your excel. You can open Excel by clicking Start Button and many
more option avialble in your operating system which we have discussed earlier. Now Click on Blank Work-
book option to open blank worksheet. As you click your mouse left button on it a Blank Worksheet will appear
as next picutre.
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Working with the Excel environment
If you have previously used Excel 2010 or 2007, Excel 2013 will feel familiar. It continues to use features like the
Ribbon and Quick Access toolbar, where you will find commands to perform common tasks in Excel, as well as
Backstage view.
The Ribbon  Excel 2013 uses a tabbed Ribbon system instead of traditional menus. The Ribbon contains multiple
tabs, each with several groups of commands. You will use these tabs to perform the most common tasks in Excel.

The Home tab gives you access to some of the most commonly used commands for working with data in Excel 2013,
including copying and pasting, formatting, and number styles. The Home tab is selected by default whenever you
open Excel.
Like Home Tab many more tab availlable in MS-Excel which name is Insert, Page Layout, Formulas, Data, Reveiw,
View and Design. We will discuss more about all these tabs later in this book.
Tip: ask your teacher in your lab about all tabs in excel ribbon.

2
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Worksheet views
Excel 2013 has a variety of viewing options that change how your workbook is displayed. You can choose to view any
workbook in Normal view, Page Layout view, or Page Break view. These views can be useful for various tasks,
especially if you are planning to print the spreadsheet.
1.  To change worksheet views, locate and select the desired worksheet view command in the bottom-right corner
of the Excel window.

Excel files are called workbooks. Whenever you start a new
project in Excel, you willll need to create a new workbook.
There are several ways to start working with a workbook in
Excel 2013. You can choose to create a new workbook—ei-
ther with a blank workbook or a predesigned template—or
open an existing workbook.

To create a new blank
workbook
1.  Select the File tab.
Backstage view will
appear.
2.  Select New, then
click Blank workbook.
3.  A new blank work-
book will appear.

Creating and Opening Workbooks

3
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To open an existing workbook:
In addition to creating new workbooks, you will often need to open a workbook that was previously saved.
1.  Navigate to Backstage view, then click Open.
2.  Select Computer, then click Browse. Alternatively, you can choose OneDrive (previously known as SkyDrive) to
open files stored on your OneDrive.

3.  The Open dialog box will appear. Locate and select your workbook, then click Open.

* If you have opened the desired workbook recently, you can browse your Recent Workbooks rather than search for
the file.

4
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A template is a predesigned spreadsheet you can use to create a new workbook quickly. Templates often include
custom formatting and predefined formulas, so they can save you a lot of time and effort when starting a new
project.
To create a new workbook from a template
1.  Click the File tab to access Backstage view.
2.  Select New. Several templates will appear below the Blank workbook option.
3.  Select a template to review it.

Using Templates

4.  A preview of the template
will appear, along with addi-
tional information on how the
template can be used.
5.  Click Create to use the se-
lected template.
6.  A new workbook will appear
with the selected template.
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*You can also browse templates by category or use the search bar to find something more specific.

*It is important to note that not all templates are created by Microsoft. Many are created by third-party providers
and even individual users, so some templates may work better than others.

Sometimes you may need to work with workbooks that were created in earlier versions of Microsoft Excel, such as
Excel 2003 or Excel 2000. When you open these types of workbooks, they will appear in Compatibility mode.
Compatibility mode disables certain features, so you will only be able to access commands found in the program
that was used to create the workbook. For example, if you open a workbook created in Excel 2003, you can only use
tabs and commands found in Excel 2003.
In the image below, you can see that the workbook is in Compatibility mode. This will disable some Excel 2013
features, such as sparklines and slicers.

Compatibility mode

In order to exit Compatibility mode, you Will need to convert the workbook to the current version type. However, if
you are collaborating with others who only have access to an earlier version of Excel, it is best to leave the workbook
in Compatibility mode so the format will not change.
To convert a workbook
If you want access to all of the Excel 2013 features, you can convert the workbook to the 2013 file format.

6
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*Note:  Converting a file may cause some changes to the original layout of the workbook.
1.  Click the File tab to access Backstage view.
2.  Locate and select Convert command.

3.  The Save As dialog box will appear. Select the location where you want to save the workbook, enter a file name
for the presentation, and click Save.

4.  The workbook will be converted to the newest file type.

7
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Saving and Sharing Workbooks
Whenever you create a new workbook in Excel, you will need to know how to save it in order to access and edit it
later. As with previous versions of Excel, you can save files locally to your computer. But unlike older versions, Excel
2013 also lets you save a workbook to the cloud using OneDrive. You can also export and share workbooks with
others directly from Excel.*OneDrive was previously called SkyDrive. There is nothing  fundamentally different about the way OneDrive works—
it is just a new name for an existing service. Over the next few months, you may still see SkyDrive in some Microsoft
products.
Save and Save As
Excel offers two ways to save a file: Save and Save As. These options work in similar ways, with a few important
differences:
Save: When you create or edit a workbook, you will use the Save command to save your changes. You will use this
command most of the time. When you save a file, you will only need to choose a file name and location the first
time. After that, you can just click the Save command to save it with the same name and location.
Save As: You will use this command to create a copy of a workbook while keeping the original. When you use Save
As, you will need to choose a different name and/or location for the copied version.
To save a workbook
It is important to save your workbook whenever you start a new project or make changes to an existing one. Saving
early and often can prevent your work from being lost. You will also need to pay close attention to where you save
the workbook so it will be easy to find later.
1.  Locate and select the Save command on the Quick Access toolbar.
2.  If you are saving the file for the first time, the Save As dialogue box will
appear in Backstage view.
3.  You will then need to choose where to save the file and give it a file
name. To save the workbook to your computer, select Computer, then click
Browse. Alternatively, you can click OneDrive to save the file to your
OneDrive.

4.  The Save As dia-
log box will appear.
Select the location
where you want to
save the workbook.
5.  Enter a file name
for the workbook,
then click Save.

8
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6.  The workbook will be saved. You can click the Save command again to save your changes as you modify the
workbook.*You can also access the Save command by pressing Ctrl+S on your
keyboard.
Auto Recover
Excel automatically saves your workbooks to a temporary folder while
you are working on them. If you forget to save your changes or if
Excel crashes you can restore the file using AutoRecover.
To use AutoRecover:
1.  Open Excel 2013. If autosaved versions of a file are found, the
Document Recovery pane will appear.
2.  Click to open an available file. The workbook will be recovered.
*By default, Excel autosaves every 10 minutes. If you are editing a
workbook for less than 10 minutes, Excel may not create an autosaved
version.
If you don not see the file you need, you can browse all autosaved
files from Backstage view. Just select the File tab, click Manage Ver-
sions, then choose Recover Unsaved Workbooks.
(See picture on the next page)
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By default, Excel workbooks are saved in the .xlsx file type. However, there may be times when you need to use
another file type, such as a PDF or Excel 97-2003 workbook. It is easy to export your workbook from Excel in a
variety of file types.
To export a workbook as a PDF file
Exporting your workbook as an Adobe Acrobat document, commonly known as a PDF (Portable Document Format)
file, can be especially useful if you are sharing a workbook with someone who does not have Excel. A PDF will make
it possible for recipients to view but not edit the content of your workbook.
1.  Click the File tab to access Backstage view.
2.  Click Export, then select Create PDF/XPS.

Exporting workbooks

3.  The Save As dialog box will appear. Select the location where you want to export the
workbook, enter a file name, then click Publish.

10
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*By default, Excel will only export the active worksheet. If you have multiple worksheets and want to save all of
them in the same PDF file, click Options in the Save as dialog box. The Options dialog box will appear. Select Entire
workbook, then click OK.
*Whenever you export a workbook
as a PDF, you will also need to con-
sider how your workbook data will
appear on each page of the PDF,
just like printing a workbook. Visit
our Page Layout lesson to learn
more about what to consider be-
fore exporting a workbook as a
PDF.
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To export a workbook in other file types
You may also find it helpful to export your workbook in other file types, such as an Excel 97-2003 workbook if you
need to share with people using an older version of Excel, or a .CSV file if you need a plain-text version of your
workbook.
1.  Click the File tab to access Backstage view.
2.  Click Export, then select Change File Type.

3.  Select a common file type, then click Save As.

12
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4.  The Save As dialog box will appear. Select the location where you want to export the workbook, enter a file
name, then click Save.

*You can also use the Save as type: drop-down menu in the Save As dialog box to save workbooks in a variety of file
types.

13
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Excel 2013 makes it easy to share and collaborate on workbooks using OneDrive. In the past, if you wanted to share
a file with someone you could send it as an email attachment. While convenient, this system also creates multiple
versions of the same file, which can be difficult to organize.
When you share a workbook from Excel 2013, you are actually giving others access to the exact same file. This lets
you and the people you share with edit the same workbook without having to keep track of multiple versions.*In order to share a workbook, it must first be saved to your OneDrive.
To share a workbook
1.  Click the File tab to access Backstage view, then click Share.
2.  The Share pane will appear.

Sharing workbooks

Cell Basics
Whenever you work with Excel, you will enter information—
or content—into cells. Cells are the basic building blocks of
a worksheet. You will need to learn the basics of cells and
cell content to calculate, analyze, and organize data in Ex-
cel.
Understanding cells
Every worksheet is made up of thousands of rectangles,
which are called cells. A cell is the intersection of a row
and a column. Columns are identified by letters (A, B, C),
while rows are identified by numbers (1, 2, 3).
Each cell has its own name—or cell address—based on its
column and row. In this example, the selected cell inter-
sects column C and row 5, so the cell address is C5. The cell
address will also appear in the Name box. Note that a cell's
column and row headings are highlighted when the cell is
selected.

14
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You can also select multiple cells at the same time. A group
of cells is known as a cell range. Rather than a single cell
address, you will refer to a cell range using the cell ad-
dresses of the first and last cells in the cell range, sepa-
rated by a colon(:). For example, a cell range that included
cells A1, A2, A3, A4, and A5 would be written as A1:A5.

In the images below, two different cell ranges are selected:
Cell range A1:A8 Cell range A1:B8

To select a cell
To input or edit cell content, you will first need to select the cell.
1.  Click a cell to select it.
2.  A border will appear around the selected cell, and the column heading
and row heading will be highlighted. The cell will remain selected until
you click another cell in the worksheet.*You can also select cells using the arrow keys on your keyboard.

To select a cell range
Sometimes you may want to select a larger group of cells, or a cell
range.
1.  Click, hold, and drag the mouse until all of the adjoining cells you
want to select are highlighted.
2.  Release the mouse to select the desired cell range. The cells will
remain selected until you click another cell in the worksheet.

15
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Cell Content
Any information you enter into a spread-
sheet will be stored in a cell. Each cell can
contain different types of content, includ-
ing text, formatting, formulas, and func-
tions.
Text  Cells can contain text, such as letters,
numbers, and dates.
Formatting attributes
Cells can contain formatting attributes that
change the way letters, numbers, and dates
are displayed. For example, percentages can
appear as 0.15 or 15%. You can even change
a cell's background color.

Formulas and functions
Cells can contain formulas and functions that calculate cell values. In our example, SUM(B2:B8) adds the value of
each cell in cell range B2:B8 and displays the total in cell B9.

To insert content
1.  Click a cell to select it.

16
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2.  Type content into the selected cell, then press Enter on your keyboard. The content will appear in the cell and the
formula bar. You can also input and edit cell content in the formula bar.

To delete cell content
1.  Select the cell with content you want to delete.

2.  Press the Delete or Backspace key on your keyboard. The cell's contents will be deleted.

*You can use the Delete key on your keyboard to delete content from multiple cells at once. The Backspace key will
only delete one cell at a time.

To delete cells
There is an important difference between deleting the con-
tent of a cell and deleting the cell itself. If you delete the en-
tire cell, the cells below it will shift up and replace the deleted
cells.
1.  Select the cell(s) you want to delete.
2.  Select the Delete command from the Home tab on the
Ribbon.
3.  The cells below will shift up.

17
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To copy and paste cell content
Excel allows you to copy content that is already entered into your
spreadsheet and paste that content to other cells, which can save
you time and effort.
1.  Select the cell(s) you
want to copy.

2.  Click the Copy command on the Home tab, or
press Ctrl+C on your keyboard. 3.  Select the cell(s) where you want to paste the content. The

copied cells will now have a dashed box around them.

4.  Click the Paste command on the Home tab, or press Ctrl+V on your keyboard.
5.  The cut contenjt will be removed from the original cells
and pasted into the selected cells.

To drag and drop cells
Rather than cutting, copying, and pasting, you can drag and drop cells to move their contents.
1.  Select the cell(s) you want to move.
2.  Hover the mouse over the border of the selected cell(s) until the cursor changes from a white cross  to a black
cross with four arrows

18
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3.  Click, hold, and drag the cells to the desired location.

To use the fill handle
There may be times when you need to copy the content of
one cell to several other cells in your worksheet. You could
copy and paste the content into each cell, but this method
would be time consuming. Instead, you can use the fill handle
to quickly copy and paste content to adjacent cells in the same
row or column.
1.  Select the cell(s) containing the content you want to use.
The fill handle will appear as a small square in the bottom-
right corner of the selected cell(s).

2.  Click, hold, and drag the fill handle until all of the cells you wantto fill are selected.
3.  Release the mouse to fill the selected cells.
4.  Release the mouse, and the cells will be dropped in the selected
location.

To continue a series with the fill handle
The fill handle can also be used to continue a series. Whenever the
content of a row or column follows a sequential order, like numbers
(1, 2, 3) or days (Monday, Tuesday, Wednesday), the fill handle can
guess what should come next in the series. In many cases, you may
need to select multiple cells before using the fill handle to help Excel
determine the series order. In our example below, the fill handle is
used to extend a series of dates in a column. (see image on next pg.)
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You can also double-click the fill handle instead of clicking and dragging. This can be useful with larger spreadsheets,
where clicking and dragging may be awkward.
To use Flash Fill
A new feature in Excel 2013, Flash Fill can enter data automatically into your worksheet, saving you time and effort.
Just like the fill handle, Flash Fill can guess what type of information you are entering into your worksheet. In the
example below, we will use Flash Fill to create a list of first names using a list of existing email addresses.
1.  Enter the desired information into your worksheet. A Flash Fill preview will appear below the selected cell
whenever Flash Fill is available.

2.  Press Enter. The Flash Fill data will be added to the worksheet.*To modify or undo Flash Fill, click the Flash Fill button next to recently added Flash Fill data.

20
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Find and Replace
When working with a lot of data in Excel, it can be difficult
and time consuming to locate specific information. You can
easily search your workbook using the Find feature, which
also allows you to modify content using the Replace fea-
ture.
To find content
In our example, we will use the Find command to locate a
specific name in a long list of employees.
1.  From the Home tab, click the Find and Select command,
then select Find... from the drop-down menu.
2.  The Find and Replace dialog box will appear. Enter the
content you want to find. In our example, we will type the
employee's name.
3.  Click Find Next. If the content is found, the cell contain-
ing that content will be selected. (refer image below)

4.  Click Find Next to find further instances or Find All to see every instance of the search term. (look image above)
5.  When you are finished, click Close to exit the Find and Replace dialog box.*You can also access the Find command by pressing Ctrl+F on your keyboard.
To replace cell content
At times, you may discover that you have repeatedly made a mistake throughout your workbook (such as misspell-
ing someone's name), or that you need to exchange a particular word or phrase for another. You can use Excel's Find
and Replace feature to make quick revisions. In our example, we will use Find and Replace to correct a list of email
addresses.
1.  From the Home tab, click the Find and Select command, then select Replace... from the drop-down menu.
(see image on next page)
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2.  The Find and Replace dialog box will appear. Type the text you want to find in the Find what: field.
3.  Type the text you want to replace it with in the Replace with: field, then click Find Next.

4.  If the content is found, the cell
containing that content will be
selected.
5.  Review the text to make sure
you want to replace it.
6.  If you want to replace it, select
one of the replace options:
Replace will replace individual in-
stances.
Replace All will replace every in-
stance of the text throughout the
workbook. In our example, we will
choose this option to save time.

22
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7.  A dialog box will appear, confirming the number of replacements made. Click OK to continue.

8.  The selected cell content will be replaced.
9.  When you are finished, click Close to exit the Find and Replace dialog box.
Modifying Columns, Rows, and Cells
By default, every row and column of a new workbook is set to the same height and width. Excel allows you to
modify column width and row height in different ways, including wrapping text and merging cells.
To modify column width
In our example below, some of the content in column A cannot be displayed.
We can make all of this content visible by changing the width of column A.
1.  Position the mouse over the column line in the column heading so the
white cross  becomes a double arrow .
2.  Click, hold, and drag the mouse to increase or decrease the column width.
3.  Release the mouse. The column width will be changed.
*If you see pound (hash) signs (#######) in a cell, it means the column is not wide enough to display the cell
content. Simply increase the column width to show the cell content
To AutoFit column width
The AutoFit feature will allow you to set a column's width to fit its content automatically.
1.  Position the mouse over the column line in the column heading so the white cross becomes a double arrow.

2.  Double-click the mouse. The column width will be changed automatically to fit the content.*You can also AutoFit the width for several columns at the same time. Simply select the columns you want to
AutoFit, then select the AutoFit Column Width command from the Format drop-down menu on the Home tab. This
method can also be used for row height.
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To modify row height
1.  Position the cursor over the row line so the white cross becomes a double
arrow.

To modify all rows or columns
Rather than resizing rows and columns individually, you can modify the height and width of every row and column at
the same time. This method allows you to set a uniform size for every row and column in your worksheet. In our
example, we will set a uniform row height.
1.  Locate and click the Select All button just below the formula bar to select every cell in the worksheet.

2.  Click, hold, and drag the mouse to increase or decrease the row height.
3.  Release the mouse. The height of the selected row will be changed.

2.  Position the mouse over a row line so the white cross becomes a double arrow.
3.  Click, hold, and drag the mouse to increase or decrease the row height.

4.  Release the mouse when you are satisfied with the new row height for the worksheet.
24
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Inserting, deleting, moving, and hid-
ing rows and columns
After you have been working with a
workbook for a while, you may find that
you want to insert new columns or
rows, delete certain rows or columns,
move them to a different location in the
worksheet, or even hide them.

3.  The new row will appear above the selected row.

*When inserting new rows, columns, or cells, you will see the Insert Options button  next to the inserted cells.
This button allows you to choose how Excel formats these cells. By default, Excel formats inserted rows with the
same formatting as the cells in the row above. To access more options, hover your mouse over the Insert Options
button, then click the drop-down arrow.

To insert rows
1.  Select the row heading below where you want the new row to appear. For example, if you want to insert a row
between rows 7 and 8, select row 8.
2.  Click the Insert command on the Home tab.

25



Richson Technoserv Opc Pvt. Ltd. MS Excel

To insert columns
1.  Select the column heading to the right of where you want the new column to appear. For example, if you want to
insert a column between columns D and E, select column E.
2.  Click the Insert command on the Home tab.

3.  The new column will appear to the left of the selected
column.
*When inserting rows and columns, make sure you select
the entire row or column by clicking the heading. If you
select only a cell in the row or column, the Insert com-
mand will only insert a new cell.
To delete rows
It is easy to delete any row that you no longer need in
your workbook.
1.  Select the row(s) you want to delete. In our example,
we will select rows 6-8.

2.  Click the Delete command on the Home tab.
3.  The selected row(s) will be deleted, and the rows be-
low will shift up.
To delete columns
1.  Select the columns(s) you want to delete.
2.  Click the Delete command on the Home tab.
3.  The selected columns(s) will be deleted, and the col-
umns to the right will shift left.*It is important to understand the difference between de-
leting a row or column and simply clearing its contents.
If you want to remove the content of a row or column
without causing others to shift, right-click a heading, then
select Clear Contents from the drop-down menu.To move a row or column

Sometimes you may want to move a column or row to rearrange the content of your worksheet. In our example we
will move a column, but you can move a row in the same way.
1.  Select the desired column heading for the column you want to move, then click the Cut command on the Home
tab or press Ctrl+X on your keyboard.
(See image on next page)
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2.  Select the column heading to the right of where you want to move the column. For example, if you want to move
a column between columns B and C, select column C.

3.  Click the Insert command on the Home tab, then select Insert Cut Cells from the drop-down menu.

4.  The column will be moved to the selected location, and
the columns to the right will shift right.
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To hide and unhide a row or column
At times, you may want to compare certain rows or columns without changing the organization of your worksheet.
Excel allows you to hide rows and columns as needed. In our example, we will hide columns C and D to make it easier
to compare columns A, B, and E.
1.  Select the column(s) you want to hide, right-click the mouse, then select Hide from the formatting menu.

2.  The columns will be hidden.
3.  To unhide the columns, select the columns to the left and right of the hidden columns (in other words, the
columns on both sides of the hidden columns). In our example, we will select columns B and E.
4.  Right-click the mouse, then select Unhide from the formatting menu. The hidden columns will reappear.
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Wrapping text and merging cells
Whenever you have too much cell content to be displayed in a single cell, you may decide to wrap the text or merge
the cell rather than resize a column. Wrapping the text will automatically modify a cell's row height, allowing cell
contents to be displayed on multiple lines. Merging allows you to combine a cell with adjacent empty cells to create
one large cell.
To wrap text in cells
In our example below, we will wrap the text of the cells in column D so the entire address can be displayed.
1.  Select the cells you want to wrap. In this example, we will select the cells in column D.

2.  Select the Wrap Text command on the Home tab.

3.  The text in the selected cells will be wrapped.*Click the Wrap Text command again to unwrap the text.
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To merge cells using the Merge & Center command
In our example below, we will merge cell A1 with cells B1:E1 to create a title heading for our worksheet.
1.  Select the cell range you want to merge.

2.  Select the Merge & Center command on the Home tab.

3.  The selected cells will be merged, and the text will be centered.

To access more merge options
1. Click the drop-down arrow next to the Merge & Center command on the Home
tab. The Merge drop-down menu will appear. From here, you can choose to:
Merge & Center: Merges the selected cells into one cell and centers the text.
Merge Across: Merges the selected cells into larger cells while keeping each row
separate.
Merge Cells: Merges the selected cells into one cell but does not center the text.
Unmerge Cells: Unmerges selected cells.
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Formatting Cells
All cell content uses the same formatting by default, which can make it difficult to read a workbook with a lot of
information. Basic formatting can customize the look and feel of your workbook, allowing you to draw attention to
specific sections and making your content easier to view and understand. You can also apply number formatting to
tell Excel exactly what type of data you are using in the workbook, such as percentages (%), currency ($), and so on.
To change the font
By default, the font of each new workbook is set to Calibri. However, Excel provides many other fonts you can use to
customize your cell text. In the example below, we will format our title cell to help distinguish it from the rest of the
worksheet.
1.  Select the cell(s) you want to modify.
2.  Click the drop-down arrow next to the Font com-
mand on the Home tab. The Font drop-down menu
will appear.
3.  Select the desired font. A live preview of the
new font will appear as you hover the mouse over
different options. In our example, we will choose
Georgia.

4.  The text will change to the selected font.*When creating a workbook in the workplace, you
will want to select a font that is easy to read. Along
with Calibri, standard reading fonts include Cambria,
Times New Roman, and Arial.
To change the font size
1.  Select the cell(s) you want to modify.
2.  Click the drop-down arrow next to the Font Size
command on the Home tab. The Font Size drop-
down menu will appear.
3.  Select the desired font size. A live preview of
the new font size will appear as you hover the mouse
over different options. In our example, we will
choose 16 to make the text larger.

4.  The text will change to the selected font size.*You can also use the Increase Font Size and Decrease Font Size
commands or enter a custom font size using your keyboard.
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To change the font color
1.  Select the cell(s) you want to
modify.
2.  Click the drop-down arrow next to
the Font Color command on the
Home tab. The Color menu will ap-
pear.
3.  Select the desired font color. A live
preview of the new font color will ap-
pear as you hover the mouse over dif-
ferent options. In our example, we will
choose Green.
4.  The text will change to the selected
font color.*Select More Colors at the bottom of
the menu to access additional color
options. To use the Bold, Italic, and Underline commands

1.  Select the cell(s) you want to modify.
2.  Click the Bold (B), Italic (I), or Underline (U) command on
the Home tab. In our example, we will make the selected cells
bold.
3.  The selected style will be applied to the text.

*You can also press Ctrl+B on your keyboard to make selected
text bold, Ctrl+I to apply italics, and Ctrl+U to apply an un-
derline.

Text alignment
By default, any text entered into your worksheet will be aligned to the bottom-left of a cell, while any numbers will
be aligned to the bottom-right. Changing the alignment of your cell content allows you to choose how the content
is displayed in any cell, which can make your cell content easier to read.
To change horizontal text alignment
In our example we will modify the alignment of our title cell to create a more polished look and further distinguish
it from the rest of the worksheet.
1.  Select the cell(s) you want to modify.
2.  Select one of the three horizontal alignment commands on the Home tab. In our example, we will choose Center
Align. (see image on next page)
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3.  The text will realign. To change vertical text alignment
1.  Select the cell(s) you want to modify.
2.  Select one of the three vertical alignment commands on the
Home tab. In our example, we will choose Middle Align.
3.  The text will realign.*You can apply both vertical and horizontal alignment settings to
any cell.

Cell borders and fill colors
Cell borders and fill colors allow you to create clear and defined
boundaries for different sections of your worksheet. Below, we will
add cell borders and fill color to our header cells to help distin-
guish them from the rest of the worksheet.
To add a border
1.  Select the cell(s) you want to modify.
2.  Click the drop-down arrow next to the Borders command on the Home tab. The Borders drop-down menu will
appear.
3.  Select the border style you want to use. In our example, we will choose to display All Borders.
4.  The selected border style will appear.
*You can draw borders and change the line style and color of borders with the Draw Borders tools at the bottom of
the Borders drop-down menu.

To add a fill color
1.  Select the cell(s) you want to modify.
2.  Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill Color menu will appear.
3.  Select the fill color you want to use. A live preview of the new fill color will appear as you hover the mouse over
different options. In our example, we will choose Light Green.
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4.  The selected fill color will appear in the selected
cells.
Format Painter
If you want to copy formatting from one cell to an-
other, you can use the Format Painter command on
the Home tab. When you click the Format Painter,
it will copy all of the formatting from the selected
cell. You can then click and drag over any cells you
want to paste the formatting to.

Cell styles
Instead of formatting cells manually, you can use Excel's predesigned
cell styles. Cell styles are a quick way to include professional format-
ting for different parts of your workbook, such as titles and headers.
To apply a cell style
In our example, we will apply a new cell style to our existing title and header cells.
1.  Select the cell(s) you want to modify.
2.  Click the Cell Styles command on the Home tab, then choose the desired style from the drop-down menu. In our
example, we will choose Accent 1.
(See image below)

3.  The selected cell style will appear.*Applying a cell style will replace any existing cell formatting except for text alignment. You may not want to use cell
styles if you have already added a lot of formatting to your workbook.
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Formatting text and numbers
One of the most powerful tools in Excel is the ability to apply specific for-
matting for text and numbers. Instead of displaying all cell content in ex-
actly the same way, you can use formatting to change the appearance of
dates, times, decimals, percentages (%), currency ($), and much more.
To apply number formatting
In our example, we will change the number format for several cells to
modify the way dates are displayed.
1.  Select the cells(s) you want to modify.
2.  Click the drop-down arrow next to the Number Format command on
the Home tab. The Number Formatting drop-down menu will appear.
3.  Select the desired formatting option. In our example, we will change
the formatting to Long Date.
4.  The selected cells will change to the new formatting style. For some
number formats, you can then use the Increase Decimal and Decrease
Decimal commands (below the Number Format command) to change the
number of decimal places that are displayed.

Explanation about aviallable number format in Excel 2013
General: General is the default format for any cell. When you enter a num-
ber into the cell, Excel will guess the number format that is most appropri-
ate.
For example, if you enter 1-5, the cell will display the number as a Short
Date, 1/5/2010.

Accounting
It  formats numbers as monetary values like the
Currency format, but it also aligns currency sym-
bols and decimal places within columns. This for-
mat makes it easier to read long lists of currency
figures.

Number
Number formats numbers with decimal places.
For example, if you enter 4 into the cell, the cell will
display the number as 4.00. Currency

Currency formats numbers as currency with a currency
symbol.
For example, if you enter 4 into the cell, the cell will dis-
play the number as $4.00.
Short Date
Short Date formats numbers as M/D/YYYY.
For example, August 8, 2018, would be 8/8/2018.
Long Date
Long Date formats numbers as Weekday, Month DD, YYYY.
For example, the date would appear as Monday, August
14, 2018.
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Text
Text formats numbers as text, meaning what you enter into
the cell will appear exactly as it was entered.
Excel defaults to this setting if a cell contains both text and
numbers.

Time
Time formats numbers as HH/MM/SS and notes AM or
PM.
For example, time would appear as 10:25:00 AM.

Percentage
Percentage formats numbers with decimal places
and the percent sign.
For example, if you enter 0.75 into the cell, the cell
will display the number as 75.00%. Fraction

Fraction formats numbers as fractions separated by the
forward slash.
For example, if you enter 1/4 into the cell, the cell will dis-
play the number as 1/4. If you enter 1/4 into a cell that is
formatted as General, the cell will display the number as a
date, 4-Jan.

Scientific
Scientific formats numbers in scientific notation.
For example, if you enter 140000 into the cell, then
the cell will display the number as 1.40E+05.
Note: By default, Excel will format the cell in sci-
entific notation if it contains a large integer. If you
do not want Excel to format large integers with
scientific notation, use the Number format.
More Number Formats
You can easily customize any format in More Num-
ber Formats.
For example, with this feature you can change the
U.S. dollar sign to another currency, have numbers
display commas, and change the number of dis-
played decimal places.
*You can click CTRL+1 from key board to oper Format Dialogue Box
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Worksheet Basics
Every workbook contains at least one worksheet by default. When working
with a large amount of data, you can create multiple worksheets to help orga-
nize your workbook and make it easier to find content. You can also group
worksheets to quickly add information to multiple worksheets at the same time.
To rename a worksheet
Whenever you create a new Excel workbook, it will contain one worksheet
named Sheet1. You can rename a worksheet to better reflect its content. In
our example, we will create a training log organized by month.
1.  Right-click the worksheet you want to rename, then select Rename from
the worksheet menu.
2. Type the desired name for the worksheet.

3.  Click anywhere outside of the worksheet, or press Enter on your
keyboard. The worksheet will be renamed.

To insert a new worksheet
1.  Locate and select the New sheet button 2.  A new blank worksheet will appear.

*To change the default number of worksheets,
navigate to Backstage view, click Options, then
choose the desired number of worksheets to in-
clude in each new workbook.
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To delete a worksheet:
1.  Right-click the worksheet you want to delete, then select Delete from the worksheet menu.

2.  The worksheet will be deleted from your workbook.

*If you want to prevent specific worksheets from being ed-
ited or deleted, you can protect them by right-clicking the
desired worksheet and then selecting Protect sheet from the
worksheet menu.

To copy a worksheet
If you need to duplicate the content of one worksheet to an-
other, Excel allows you to copy an existing worksheet.
1.  Right-click the worksheet you want to copy, then select Move
or Copy from the worksheet menu.
2.  The Move or Copy dialog box will appear. Choose where the
sheet will appear in the Before sheet: field. In our example, we
will choose (move to end) to place the worksheet to the right
of the existing worksheet.
3.  Check the box next to Create a copy, then click OK.

4.  The worksheet will be copied. It will have the same title as the original worksheet, as well as a version number.
In our example, we copied the January worksheet, so our new worksheet is named January (2). All content from the
January worksheet has also been copied to the January (2) worksheet.
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*You can also copy a worksheet to an entirely different workbook. You can select any workbook that is currently
open from the To book: drop-down menu.

To move a worksheet
Sometimes you may want to move a worksheet to rearrange your workbook.
1.  Select the worksheet you want to move. The cursor will become a small worksheet icon .
2.  Hold and drag the mouse until a small black arrow appears above the desired location.

3.  Release the mouse. The worksheet will be moved.
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To change the worksheet tab color
You can change a worksheet tab's color to help organize your worksheets and make your workbook easier to navi-
gate.
1.  Right-click the desired worksheet tab, and hover the mouse over Tab Color. The Color menu will appear.
2.  Select the desired color. A live preview of the new worksheet tab color will appear as you hover the mouse over
different options. In our example, we will choose Red.

3.  The worksheet tab color will be changed.

Switching between worksheets
If you want to view a different worksheet, you can simply click the tab to switch to that worksheet. However, with
larger workbooks this can sometimes become tedious, as it may require scrolling through all of the tabs to find the
one you want. Instead, you can simply right-click the scroll arrows in the lower-left corner, as shown below.

A dialog box will appear with a list of all of the sheets in your work-
book. You can then double-click the sheet you want to jump to.

To group worksheets
In our example, employees need to receive training every three months, so we will create a worksheet group for
those employees. When we add the names of the employees to one worksheet, they will be added to the other
worksheets in the group as well.
1.  Select the first worksheet you want to include in the worksheet group.
2.  Press and hold the Ctrl key on your keyboard.

Grouping and ungrouping worksheets
You can work with each worksheet individually, or you can work
with multiple worksheets at the same time. Worksheets can be

combined together into a group. Any changes made to one worksheet in a group will be made to every worksheet
in the group.
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4.  Release the Ctrl key. The worksheets are now grouped.*While worksheets are grouped, you can navigate to any
worksheet within the group. Any changes made to one
worksheet will appear on every worksheet in the group.
However, if you select a worksheet that is not in the group,
all of your worksheets will become ungrouped.

To ungroup all worksheets
1.  Right-click a worksheet in the group, then select Ungroup Sheets from the worksheet menu.

2.  The worksheets will be ungrouped. Alternatively, you can simply click any worksheet not included in the group to
ungroup all worksheets.
Page Layout
Many of the commands you will use to prepare your workbook for printing and PDF export can be found on the Page
Layout tab. These commands let you control the way your content will appear on a printed page, including the page
orientation and margin size. Other page layout options, such as print titles and page breaks, can help make your
workbook easier to read.
Page Layout view
Before you start modifying a workbook's page layout, you may want to view the workbook in Page Layout view,
which can help you visualize your changes.
To access Page Layout view, locate and select the Page Layout view command in the bottom-right corner of your
workbook.

Page orientation
Excel offers two page orientation options: landscape and portrait. Landscape orients the page horizontally, while
portrait orients the page vertically. Portrait is especially helpful for worksheets with a lot of rows, while landscape is
best for worksheets with a lot of columns. In the example below, portrait orientation works best because the worksheet
includes more rows than columns.

3.  Select the next worksheet you want in the group. Continue to select worksheets until all of the worksheets you
want to group are selected.
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To change page orientation
1.  Click the Page Layout tab on the Rib-
bon.
2.  Select the Orientation command, then
choose either Portrait or Landscape from
the drop-down menu.
3.  The page orientation of the workbook
will be changed.
To format page margins
A margin is the space between your content and the edge of the page. By default, every workbook's margins are set
to Normal, which is a one-inch space between the content and each edge of the page. Sometimes you may need to
adjust the margins to make your data fit more comfortably on the page. Excel includes a variety of predefined
margin sizes.

To use custom margins
Excel also allows you to customize the size of your margins in the Page Setup
dialog box.
1.  From the Page Layout tab, click Margins. Select Custom Margins... from the
drop-down menu.
2.  The Page Setup dialog box will appear.
3.  Adjust the values for each margin, then click OK.
4.  The margins of the workbook will be changed.

1.  Click the Page Layout tab on the Ribbon, then select the Margins command.
2.  Select the desired margin size from the drop-down menu. In our example,
we will select Narrow to fit more of our content on the page.
3.  The margins will be changed to the selected size.
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To include Print Titles
If your worksheet uses title headings, it is important to in-
clude these headings on each page of your printed worksheet.
It would be difficult to read a printed workbook if the title
headings appeared only on the first page. The Print Titles com-
mand allows you to select specific rows and columns to ap-
pear on each page.
1. Click the Page Layout tab on the Ribbon, then select the
Print Titles command.

2.  The Page Setup dialog box will appear. From here, you can choose rows or columns to repeat on each page. In
our example, we will repeat a row.
2.  Click the Collapse Dialog button next to the Rows to repeat at top: field.

4.  The cursor will be-
come a small selection
arrow  and the Pagee
Setup dialog box will be
collapsed. Select the
row(s) you want to re-
peat at the top of each
printed page. In our ex-
ample, we will select
row 1.
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5.  Row 1 will be added to the Rows to repeat at top: field. Click the Collapse Dialog button again.

6.  The Page Setup dialog box will expand. Click OK. Row 1 will be printed at the top of every page.
To insert a page break
If you need to print different parts of your workbook across separate pages, you can insert a page break. There are
two types of page breaks: vertical and horizontal. Vertical page breaks separate columns, while horizontal page
breaks separate rows. In our example, we will insert a horizontal page break.
1.  Locate and select the Page Break view command. The worksheet will appear in Page Break view.

2.  Select the row below where you want the page break to appear. For example, if you want to insert a page break
between rows 28 and 29, select row 29.

3.  Click the Page Layout tab on the Ribbon, select the Breaks command, then click Insert Page Break.
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4.  The page break will be inserted, represented by a dark blue line.

*When viewing your workbook in Normal view, inserted page breaks are represented by a solid gray line, while
automatic page breaks are represented by a dashed line.

To insert headers and footers:
You can make your workbook easier to read and look more professional by including headers and footers. The
header is a section of the workbook that appears in the top margin, while the footer appears in the bottom margin.
Headers and footers generally contain information such as page number, date, and workbook name.
1.  Locate and select the Page Layout view command at the bottom of the Excel window. The worksheet will appear
in Page Layout view.

2.  Select the header or footer you want to modify. In our example, we will modify the footer at the bottom of the
page.
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3.  The Header & Footer Tools tab will appear on the Ribbon. From here, you can access commands that will auto-
matically include page numbers, dates, and workbook names. In our example, we will add page numbers.

4.  The footer will change to include page numbers automatically.
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Printing Workbooks
There may be times when you want to print a workbook to view and share your data offline. Once you have chosen
your page layout settings, it is easy to preview and print a workbook from Excel using the Print pane.
To access the Print pane
1.  Select the File tab. Backstage view will appear.
2.  Select Print. The Print pane will appear.

To print a workbook
1. Navigate to the Print
pane, then select the de-
sired printer.
2. Enter the number of
copies you wish to print.
3. Select any additional
settings if needed (see
image beside).
4. Click Print.
Choosing a print area
Before you print an Excel
workbook, it is important
to decide exactly what in-
formation you want to
print. For example, if you
have multiple worksheets
in your workbook, you
will need to decide if you
want to print the entire
workbook or only active
worksheets. There may

also be times when you want to print only a selection of content from your workbook.

To print active sheets
Worksheets are considered active when selected.
1.  Select the worksheet you want to print. To print multiple worksheets, click the first worksheet, hold the Ctrl key
on your keyboard, then click any other worksheets you want to select.

2.  Navigate to the Print pane.
3.  Select Print Active Sheets from the Print Range drop-down menu.
4.  Click the Print button.
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To print the entire workbook
1.  Navigate to the Print pane.
2.  Select Print Entire Workbook from the Print Range drop-down menu.
3.  Click the Print button.

2.  Navigate to the Print pane.
3.  Select Print Selection from the Print
Range drop-down menu.

To print a selection
In our example, we will print a selection of content related to upcoming softball games in July.
1.  Select the cells you want to print.

4.  A preview of your selection will appear in the Preview pane.
5.  Click the Print button to print the selection.*If you prefer, you can also set the print area in advance so you will be able
to visualize which cells will be printed as you work in Excel. Simply select the
cells you want to print, click the Page Layout tab, select the Print Area com-
mand, then choose Set Print Area.

Fitting and scaling content
On occasion, you may need to make small adjustments from the Print pane to fit your workbook content neatly
onto a printed page. The Print pane includes several tools to help fit and scale your content, such as scaling and page
margins.
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To fit content before printing
If some of your content is being cut off by the printer, you can use scaling to fit your workbook to the page automati-
cally.
1.  Navigate to the Print pane. In our example, we can see in the Preview pane that our content will be cut off when
printed.

2.  Select the desired option from the Scaling drop-down menu. In our
example, we will select Fit Sheet on One Page.

3.  The worksheet will be condensed to fit onto a single page.
4.  When you are satisfied with the scaling, click Print.
Simple Formulas
One of the most powerful features in Excel is the ability to calculate numerical information using formulas. Just like
a calculator, Excel can add, subtract, multiply, and divide. In this lesson, we will show you how to use cell references
to create simple formulas.
Mathematical operators
Excel uses standard operators for formulas, such as a plus sign for addition (+), a minus sign for subtraction (-), an
asterisk for multiplication (*), a forward slash for division (/), and a caret (^) for exponents.

All formulas in Excel must begin with an equals sign (=). This is because the
cell contains, or is equal to, the formula and the value it calculates.
Understanding cell references
While you can create simple formulas in Excel manually (for example, =2+2 or
=5*5), most of the time you will use cell addresses to create a formula. This is
known as making a cell reference. Using cell references will ensure that your
formulas are always accurate because you can change the value of referenced
cells without having to rewrite the formula.
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By combining a mathematical operator with cell references,
you can create a variety of simple formulas in Excel. For-
mulas can also include a combination of cell references and
numbers, as in the examples below:

To create a formula
In our example below, we will use a simple for-
mula and cell references to calculate a budget.
1.  Select the cell that will contain the formula.
In our example, we will select cell B3.

2.  Type the equals sign (=). Notice how it appears in both the
cell and the formula bar.

3.  Type the cell address of the cell you
want to reference first in the formula:
cell B1 in our example. A blue border
will appear around the referenced cell.

4.  Type the mathematical operator you want to use. In our example, we will type the addition sign (+).
5.  Type the cell address of the cell you want to reference second in the formula: cell B2 in our example. A red border
will appear around the referenced cell.

6.  Press Enter on your keyboard. The
formula will be calculated, and the
value will be displayed in the cell.

*If the result of a formula is too large to be displayed in a cell, it may appear as pound signs (#######) instead of a
value. This means the column is not wide enough to display the cell content. Simply increase the column width to
show the cell content.
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Complex  Formulas
A simple formula is a mathematical expression with one operator, such as 7+9. A complex formula has more than
one mathematical operator, such as 5+2*8. When there is more than one operation in a formula, the order of
operations tells Excel which operation to calculate first. In order to use Excel to calculate complex formulas, you will
need to understand the order of operations.
The order of operations
Excel calculates formulas based on the following order of operations:
1.  Operations enclosed in parentheses.
2.  Exponential calculations (3^2, for example).
3.  Multiplication and division, whichever comes first.
4.  Addition and subtraction, whichever comes first.
Creating complex formulas
In the example below, we will demonstrate how Excel solves a complex formula using the order of operations. Here,
we want to calculate the cost of sales tax for a catering invoice. To do this, we will write our formula as =(D2+D3)*0.075
in cell D4. This formula will add the prices of our items together and then multiply that value by the 7.5% tax rate
(which is written as 0.075) to calculate the cost of sales tax.

Excel follows the order of operations and first adds
the values inside the parentheses: (44.85+39.90) =
$84.75. It then multiplies that value by the tax rate:
$84.75*0.075. The result will show that the sales
tax is $6.36.

A function is a predefined formula that performs calculations using specific values in a particular order. Excel in-
cludes many common functions that can be useful for quickly finding the sum, average, count, maximum value, and
minimum value for a range of cells. In order to use functions correctly, you will need to understand the different
parts of a function and how to create arguments to calculate values and cell references.
The parts of a function
In order to work correctly, a function must be written a specific way, which is called the syntax. The basic syntax for
a function is the equals sign (=), the function name (SUM, for example), and one or more arguments. Arguments
contain the information you want to calculate. The function in the example below would add the values of the cell
range A1:A20.

Functions
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Working with arguments
Arguments can refer to both individual cells and cell
ranges and must be enclosed within parentheses. You
can include one argument or multiple arguments, de-
pending on the syntax required for the function.
For example, the function =AVERAGE(B1:B9) would cal-
culate the average of the values in the cell range B1:B9.
This function contains only one argument.
Multiple arguments must be separated by a comma. For
example, the function =SUM(A1:A3, C1:C2, E1) will add
the values of all the cells in the three arguments.

Creating a function
Excel has a variety of functions available. Here are
some of the most common functions you will use:
SUM: This function adds all of the values of the cells
in the argument.
AVERAGE: This function determines the average of
the values included in the argument. It calculates

the sum of the cells and then divides that value by the number of cells in the argument.
COUNT: This function counts the number of cells with numerical data in the argument. This function is useful for
quickly counting items in a cell range.
MAX: This function determines the highest cell value included in the argument.
MIN: This function determines the lowest cell value included in the argument.
To create a basic function
In our example below, we will
create a basic function to calcu-
late the average price per unit
for a list of recently ordered
items using the AVERAGE func-
tion.
1.  Select the cell that will con-
tain the function. In our ex-
ample, we will select cell C11.

2.  Type the equals sign (=) and enter the desired function name. You can also select the desired function from the
list of suggested functions that will appear below the cell as you type. In our example, we will type =AVERAGE.
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3.  Enter the cell range for the argument inside parentheses. In our example, we Will type (C3:C10). This formula
will add the values of cells C3:C10 and then divide that value by the total number of cells in the range to determine
the average.

4.  Press Enter on your keyboard. The function will be calcu-
lated, and the result will appear in the cell. In our example,
the average price per unit of items ordered was $15.93.

2.  In the Editing group on the Home tab, locate
and select the arrow next to the AutoSum com-
mand and then choose the desired function
from the drop-down menu. In our example, we
will select Sum.

To create a function using the AutoSum command
The AutoSum command allows you to automatically insert the most common functions into your formula, including
SUM, AVERAGE, COUNT, MIN, and MAX. In our example below, we will create a function to calculate the total cost
for a list of recently ordered items using the SUM function.
1.  Select the cell that will contain the function. In our example, we will select cell D12.
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3.  The selected function will appear in the cell. If logically placed, the AutoSum command will automatically select
a cell range for the argument. In our example, cells D3:D11 were selected automatically and their values will be
added together to calculate the total cost. You can also manually enter the desired cell range into the argument.

4.  Press Enter on your keyboard. The function will be cal-
culated, and the result will appear in the cell. In our ex-
ample, the sum of D3:D11 is $606.05.
*The AutoSum command can also be accessed from the
Formulas tab on the Ribbon.
You can also use the Alt+= keyboard shortcut instead of
the AutoSum command. To use this shortcut, hold down
the Alt key and then press the equals sign.

The Function Library
While there are hundreds of functions in Excel, the ones you use most frequently will depend on the type of data
your workbooks contains. There is no need to learn every single function, but exploring some of the different types
of functions will be helpful as you create new projects. You can search for functions by category, such as Financial,
Logical, Text, Date & Time, and more from the Function Library on the Formulas tab.
To access the Function Library, select the Formulas tab on the Ribbon. The Function Library will appear.

To insert a function from the Function Library:
In our example, we will use a function to calculate the number of business days it took to receive items after they
were ordered. In our example, we will use the dates in columns B and C to calculate the delivery time in column D.
1.  Select the cell that will contain the function. In our example, we will select cell D3.
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2.  Click the Formulas tab on the Ribbon
to access the Function Library.
3.  From the Function Library group, se-
lect the desired function category. In our
example, we Will choose Date & Time.
4.  Select the desired function from the
drop-down menu. In our example, we will
select the NETWORKDAYS function to
count the number of business days be-
tween the ordered date and received date.

5.  The Function Arguments dialog box will ap-
pear. From here, you will be able to enter or se-
lect the cells that will make up the arguments in
the function. In our example, we will enter B3 in
the Start_date: field and C3 in the End_date: field.
6.  When you are satisfied with the arguments,
click OK.

The Insert Function command
If you are having trouble finding the right function, the Insert Function command allows you to search for functions
using keywords. While it can be useful, this command is sometimes difficult to use. If you do not have much experi-
ence with functions, you may have more success browsing the Function Library instead. For more advanced users,
however, the Insert Function command can be a powerful way to find a function quickly.
To use the Insert Function command
In our example below, we want to find a function that will count the total number of items ordered. We want to
count the cells in the Item column, which uses text. We cannot use the basic COUNT function because it will only

7.  The function will be calculated, and the result will appear in the cell. In our example, the result shows that it took
four business days to receive the order.

*Like formulas, functions can be copied to
adjacent cells. Hover the mouse over the
cell that contains the function, then click,
hold, and drag the fill handle over the cells
you want to fill. The function will be cop-
ied, and values for those cells will be cal-
culated relative to their rows or columns.
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count cells with numerical information. Instead, we will need to find a function that counts the total number of cells
within a cell range.
1.  Select the cell that will contain the function. In our example, we will select cell B16.

2.  Click the Formulas tab on the Ribbon, then se-
lect the Insert Function command.

3.  The Insert Function dialog box will appear.
4.  Type a few keywords describing the calculation
you want the function to perform, then click Go. In
our example, we will type Count cells, but you can
also search by selecting a category from the drop-
down list.

5.  Review the re-
sults to find the de-
sired function, then
click OK. In our ex-
ample, we will
choose COUNTA
because it will
count the number
of cells in a cell
range.
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6.  The Function Arguments dialog box will appear.
Select the Value1: field, then enter or select the
desired cells. In our example, we will enter the cell
range A3:A10. You may continue to add arguments
in the Value2: field, but in this case we only want
to count the number of cells in the cell range
A3:A10.
7.  When you are satisfied, click OK.
8.  The function will be calculated, and the result
will appear in the cell. In our example, the result
shows that a total of eight items were ordered.

Microsoft Excel Function List
Excel provides many more library functions to calcuate your mathematical calculation in worksheets some are ex-
plained below:
Mathematical Functions
SUM - Adds up all the values in a range
The most commonly used Excel function is Sum. The purpose of the Sum function is to add up the numbers in a
range.
1.  Select the cell where you wish the total to appear.
2.  Click the Sum  button The SUM button on the toolbar
3.  The Sum function appears in the cells and a dotted line appears around the cells Excel thinks you want to add. If
the range is not correct, select a different range.

4.  Press Enter
The total appears in the cell. If a value in the summed range
changes at a later date, the total will automatically update it-
self.
The Sum function can add more than one range if needed. To
select a second range, enter a comma and select another range.
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SUMIF
The SUMIF function totals the values of a range that meet specific criteria. For example it will total only the orders
from a specific company or after a specific date.
The syntax for SUMIF is:
=SUMIF(range, criteria, [sum_range])

SUMIFS Function
The Excel SUMIFS function is similar to the SUMIF
function. It adds up the values from a given range
that meets multiple criteria.
The syntax for the SUMIFS function is:
=SUMIFS (sum_range, criteria_range1, criteria1, ...)

SUMPRODUCT Function
The Excel SUMPRODUCT function is a hidden gem.
The purpose of the SUMPRODUCT function is to re-
turn the sum of products  from 1 or more arrays.
Now this may not sound that useful, but let me ex-
plain further. It’s syntax is:
=SUMPRODUCT(array1, [array2], [array3], ...)
The SUMPRODUCT function works by multiplying a
group of numbers and then adding the results. Each
array of SUMPRODUCT is a range of values. These
arrays must be of the same dimension.

ROUND Functions
The Excel ROUND function is used to round a number to a specified number of digits. For example, round a number
to the one decimal place.
The syntax for the ROUND function is:
=ROUND(number,num_digits)
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ROUNDDOWN Function
The Excel ROUNDDOWN function is used to round a number
down to a specified number of digits. For example, round a
number down to one decimal place.
The syntax for the ROUNDDOWN function is:
=ROUNDDOWN(number,num_digits)

CEILING Function
The Excel CEILING function is used to round a number
up to a multiple of significance. For example, you could
round a number up to 2 decimal places, or to the next
multiple of 5.
The syntax for the CEILING function is:
=CEILING(number,significance)

FLOOR Function
The Excel FLOOR function is used to round a number
down to a multiple of significance. For example, you
could round a number down to the nearest decimal
place, or to the next multiple of 5.
The syntax for the FLOOR function is:
=FLOOR(number,significance)

ROUNDUP Functions
The Excel ROUNDUP function is used to round a number up to a specified number of digits.For example, round a
number up to one decimal place.
The syntax for the ROUNDUP function is:
=ROUNDUP (number,num_digits)
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Statical Functions
Count
Returns the number of values from a list.
The syntax for the Count function is:
=COUNT(value1, [value2], ...)

Average
Returns the average or arithmetic mean of a
list of values.
The syntax for the Average function is:
=AVERAGE(number1, [number2], ...)

Min
Returns the smallest number from a list of values.
The syntax for the Min function is:
=MIN(number1, [number2], ...)
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Max
Returns the largest number from a list of values.
The syntax for the Max function is:
=MAX(number1, [number2], ...)
COUNTBLANK Function
The COUNTBLANK function counts the empty
cells in a given range.
The syntax for the COUNTBLANK function is:
=COUNTBLANK(range)

CountIf
The COUNTIF function counts the number of val-
ues in a range that meet specific criteria. For ex-
ample it will return how many orders were placed
by a specific company or after a specific date.
The syntax for COUNTIF is:
=COUNTIF(range, criteria)
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COUNTA Function
The COUNTA function counts the number of non empty cells
in a given range. COUNTA will count cells containing values,
labels and formulas.
The syntax for the COUNTA function is:
=COUNTA(value1,value2,...)

COUNTIFS Function
The Excel COUNTIFS function is similar to the
COUNTIF function. It counts all the cells from a
given range that meets multiple criteria.
The syntax for the COUNTIFS function is:
=COUNTIFS(criteria_range1, criteria1, ...)

AVERAGEIF
The Excel AVERAGEIF function is used to find the
average value from a range of cells that meet cer-
tain criteria.
The syntax for the AVERAGEIF function is:
=AVERAGEIF(range, criteria, [average_range])
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AVERAGEIFS Function
The Excel AVERAGEIFS function is used to find the
average value from a range of cells that meet
multiple criteria.
The syntax for the AVERAGEIFS function is:
=AVERAGEIFS(average_range, criteria_range,
criteria, ...)

LARGE Function
The Excel LARGE function is used to return a value
dependent upon its ranking in a range of values. For
example, the LARGE function can be used to return
the 2nd or 3rd largest number from a range.
The syntax for the LARGE function is:
=LARGE(array,k)

SMALL Function
The Excel SMALL function is used to return a value
dependent upon its ranking in a range of values. For
example, the SMALL function can be used to return
the 2nd or 3rd smallest number from a range.
The syntax for the SMALL function is:
=SMALL(array,k)

RANK Functions
The RANK function returns the rank or position of a number within
a range of numbers.
Duplicate numbers are given the same rank. This then affects the
ranking of subsequent numbers. For example, if number 8 ap-
pears twice and has a rank of 4, then 9 would have a rank of 6
and no number would be ranked number 5.
The syntax for the RANK function is:
=RANK(number, ref, [order])

Text Functions
LEN Function
The Excel LEN function is used to find the length, in num-
ber of characters, of the contents of a cell.
The syntax for the LEN function is:
=LEN(text)
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REPT Function
The Excel REPT function is used to repeat text a given
number of times in a cell.
The syntax for the REPT function is:
=REPT(text,number_times)
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TRIM Function
The Excel TRIM function is used to remove un-
wanted spaces from cells. These unwanted spaces
are usually generated when importing or copying
text data into Excel.
The syntax for the TRIM function is:
=TRIM(text)
LEFT Function
The LEFT function is used to extract a specific number of characters
from the start of a cell.
This can be useful to when needing to remove unwanted characters
in a cell that appear on the right of the cells content. This can happen
as a result of importing data into Excel from another application or
database.
The syntax for the LEFT function is:
=LEFT(text, [num_chars])
RIGHT Function
The RIGHT function is used to extract a specific
number of characters from the end of a cell.
This can be useful to when needing to remove un-
wanted characters in a cell that appear on the left
of the cells content. This can happen as a result of
importing data into Excel from another applica-
tion or database.
The syntax for the RIGHT function is:
=RIGHT(text, [num_chars])
MID Function
The MID function is used to extract a specific number of
characters from the middle of a cell.
This can be useful to when needing to remove unwanted
characters in a cell that appear on the left and right of the
cells content. This can happen as a result of importing data
into Excel from another application or database.
The syntax for the MID function is:
=MID(text, start_num, num_chars)
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LOWER Function
The LOWER function is used to convert the text in a cell to
lowercase.
The syntax for the LOWER function is:
=LOWER(text)
PROPER Function
The PROPER function is used to convert the first character of
each word in a cell to uppercase and the remaining charac-
ters to lowercase.
The syntax for the PROPER function is:
=PROPER(text)
REPLACE Function
The Excel REPLACE function is used to replace existing
characters in a cell with a different set of characters,
or with nothing. These unwanted characters can ap-
pear as a result of importing or copying data into Excel.
The syntax for the REPLACE function is:
=REPLACE(old_text, start_num, num_chars, new_text)

Financial Functions
PMT Function
The Excel PMT function is used to calculate loan repay-
ments based on constant payments and a constant inter-
est rate.
The syntax for the PMT function is:
=PMT(rate, nper, pv, [fv], [type])
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UPPER Function
The UPPER function is used to convert the text in a cell to
uppercase.
The syntax for the UPPER function is:
=UPPER(text)
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RATE Function
The Excel RATE function is used to return the
interest rate per period of a loan or invest-
ment.
The syntax for the RATE function is:
=RATE(nper, pmt, pv, [fv], [type], [guess])
PV Function
The Excel PV function is used to return the
present value of an investment based on a
constant interest rate and payments.
The syntax for the PV function is:
=PV(rate, nper, pmt, [fv], [type])
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FV Function
The Excel FV function is used to return the future value of an
investment based on constant payments and a constant interest
rate.
The syntax for the FV function is:
= FV (rate, nper, pmt, [pv], [type])

IPMT Function
The Excel IPMT function is used to calculate the interest
paid during a period of a loan or investment.
It could be used by an investment company to find out the
interest earned on a loan given to a customer. The IPMT
function could be used to decide what interest rate to ap-
ply to the loan, as changing the rate will change the po-
tential interest earned, ensuring the loan is worth giving.
The IPMT function can also be used to find out the amount
of interest earned during a specific period during the length
of a loan or investment, such as the 3rd year.
The syntax for the IPMT function is:
=IPMT(rate, per, nper, pv, [fv], [type])

IRR Function
The Excel IRR function is used to return the internal
rate of return based on a series of investments. The
investments must occur at regular intervals such as
weekly, bi-weekly or monthly.
The syntax for the IRR function is:
=IRR(values, [guess])
PPMT Function
The Excel PPMT function is used to calculate the princi-
pal payment made in a period of an investment. Where
as IPMT calculates the interest paid in a period of an
investment, PPMT relates to the amount paid that comes
of the balance.
The syntax for the PPMT function is:
=PPMT(rate, per, nper, pv, [fv], [type])
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XIRR Function
The Excel XIRR function is used to return the internal rate
of return based on a series of irregular payments on an
investment.
The syntax for the XIRR function is:
=IRR(values, dates, [guess])
NPV Function
The Excel NPV function is used to return the net
present value of an investment based on a series of
cash flows and a discount rate.
The syntax for the NPV function is:
=NPV(rate, value1, [value2], ...)

XNPV Function
The Excel XNPV function returns the net present value of an invest-
ment based on a series of cash flows, the dates of the cash flows
and a discount rate.
The syntax for the XNPV function is:
=XNPV(rate, values, dates)

Lookup and Reference Functions
Vlookup Function
The Excel Vlookup function is a lookup and reference function. It
searches for a record of data in a list and returns information from
that record. For example, it could search a list of orders and return
the value of an order that you ask for.
Vlookup stands for Vertical Lookup. It gets this name because it looks
down columns. You would be right to assume that there is also an
Hlookup that looks along rows.
Vlookup requires 4 items of information (arguments) in order to work.
=vlookup(lookup_value,table_array,col_index_num,[range_lookup])

INDEX Function
The INDEX function returns an item from
a specific position in a list.
The syntax for the INDEX function is:
=INDEX(array, row_num, [column_num])
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MATCH Function
The MATCH function returns the position of an item
within a range of cells
The syntax for the MATCH function is:
=MATCH(lookup_value, lookup_array, [match_type])

INDIRECT Function
Ensure the reference does not change when additional
rows and columns are inserted in the worksheet.
Create a reference from letters and numbers entered into
other cells. This also enables you to change the reference
in the formula without editing the formula itself.
Refer to a named range. Very useful when used with Data
Validation to create dependent drop down lists
The syntax for the INDIRECT function is:
=INDIRECT(ref_text, [a1])

CHOOSE Function
The CHOOSE function in Excel returns a value from a list of val-
ues based on a specified position.
The syntax for the CHOOSE function is:
=CHOOSE(index_num, value1, [value2], ...)

OFFSET Function
The OFFSET function returns a value from a cell, or
range of cells that are a specified number of rows and
columns from another cell.
The syntax for the OFFSET function is:
=OFFSET(reference, rows, columns, [height], [width])
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ADDRESS Function
The ADDRESS function in Excel returns a text represen-
tation of a cell address from specified row and column
numbers.
The syntax for the ADDRESS function is:
=ADDRESS(row_num, column_num, [abs_num], [a1],
[sheet_text])

Logical Functions
IF function
The IF function can perform a logical test and return one
value for a TRUE result, and another for a FALSE result. For
example, to "pass" scores above 70:
=IF(A1>70,"Pass","Fail"). More than one condition can be
tested by nesting IF functions. The IF function can be com-
bined with logical functions like AND and OR.
Purpose
Test for a specific condition
Return  value
The values you supply for TRUE or FALSE
Syntax
=IF (logical_test, [value_if_true], [value_if_false])
Arguments
logical_test - A value or logical expression that can be evalu-
ated as TRUE or FALSE.
value_if_true - [optional] The value to return when
logical_test evaluates to TRUE.
value_if_false - [optional] The value to return when
logical_test evaluates to FALSE.
Nested IF statements
You may here the term "Nested IF" or "Nested IF statement".
This refers to using more than one IF function so that you
can test for more conditions and return more possible re-
sults. Each IF statement needs to be carefully "nested" in-
side another so that the logic is correct.

For example, the following formula can be used to assign an grade rather than a pass / fail result:
=IF(C6<70,"F",IF(C6<75,"D",IF(C6<85,"C",IF(C6<95,"B","A"))))
AND Function
The AND function is a logical function used to require more than one condition at the same time. AND returns either
TRUE or FALSE. To test if a number in A1 is greater than zero and less than 10, use =AND(A1>0,A1<10). The AND
function can be used as the logical test inside the IF function to avoid extra nested IFs, and can be combined with the
OR function.
Purpose
Test multiple conditions with AND
Return  value
TRUE if all arguments evaluate TRUE; FALSE if not
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Syntax
=AND (logical1, [logical2], ...)
Arguments
logical1 - The first condition or logical value to evaluate.
logical2 - [optional] The second condition or logical value to evaluate.
OR Function
The OR function is a logical function to test multiple conditions at the same time. OR returns either TRUE or FALSE.
For example, to test A1 for either "x" or "y", use =OR(A1="x",A1="y"). The OR function can be used as the logical
test inside the IF function to avoid extra nested IFs, and can be combined with the AND function.
Purpose
Test multiple conditions with OR
Return value
TRUE if any arguments evaluate TRUE; FALSE if not.
Syntax
=OR (logical1, [logical2], ...)
Arguments
logical1 - The first condition or logical value to evaluate.
logical2 - [optional] The second condition or logical value to evaluate.
IFERROR Function
The Excel IFERROR function returns a custom result when a formula generates an error, and a standard result when
no error is detected. IFERROR is an elegant way to trap and manage errors without using more complicated nested
IF statements.
Purpose
Trap and handle errors
Return  value
The value you specify for error conditions.
Syntax
=IFERROR (value, value_if_error)
Arguments
value - The value, reference, or formula to check for an error.
value_if_error - The value to return if an error is found.
Date & Time Functions
TODAY Function
The Excel TODAY function returns the current date, updated continuously when a worksheet is changed or opened.
The TODAY function takes no arguments. You can format the value returned by TODAY using any standard date
format. If you need current date and time, use the NOW function.
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Purpose
Get the current date
Return value
A serial number representing a particular date in Excel.
Syntax
=TODAY ()
NOW Function
The Excel NOW function returns the current date and time, updated continuously when a worksheet is changed or
opened. The NOW function takes no arguments. You can format the value returned by NOW as a date, or as a date
with time by applying a number format.
Purpose
Get the current date and time
Return value
A serial number representing a particular date and time in Excel.
Syntax
=NOW ()
DATE Function
The Excel DATE function is a built-in function that allows you to create a date with individual year, month, and day
components. The DATE function is especially useful when supplying dates as inputs to other functions like SUMIFS or
COUNTIFS, since you can easily assemble a date using year, month, and day values that come from a cell reference
or formula result.
Purpose
Create a valid date from year, month, and day
Return value
A serial number that represents a particular date in Excel.
Syntax
=DATE (year, month, day)
Arguments
year - The year to use when creating the date.
month - The month to use when creating the date.
day - The day to use when creating the date.
DAY Function
The Excel DAY function returns the day of the month as a number between 1 to 31 when given a date. You can use
the DAY function to extract a day number from a date into a cell. You can also use the DAY function to feed a day
value into another formula, like the DATE function.
Purpose
Get the day as a number (1-31) from a date
Return value
A number (1-31) representing the day component in a date.
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Syntax
=DAY (date)
Arguments
date - A valid Excel date in serial number format.
MONTH Function
The Excel MONTH function returns the month portion of a date as number between 1 to 12 when given a date. You
can use the MONTH function to extract a month number from a date into a cell. You can also use the MONTH
function to feed a month number to another formula, like the DATE function.
Purpose
Get the month as a number (1-12) from a date
Return value
A number between 1 and 12.
Syntax
=MONTH (date)
Arguments
date - A valid date in a format Excel recognizes.
YEAR Function
The Excel YEAR function returns the year component of a date as a 4-digit number. You can use the YEAR function to
extract a year number from a date into a cell. You can also use the YEAR function to extract and feed a year value into
another formula, like the DATE function.
Purpose
Get the year from a date
Return value
A number representing year.
Syntax
=YEAR (date)
Arguments
date - A date from which to extract the year.
WORKDAY Function
The Excel WORKDAY function takes a date and returns the nearest working day in the future or past, based on an
offset value you provide. You can use the WORKDAY function to calculate things like ship dates, delivery dates, and
completion dates that need to take into account working and non-working days.
Purpose
Get a date n working days in the future or past
Return value
A serial number representing a particular date
in Excel.
Syntax
=WORKDAY (start_date, days, [holidays])

Arguments
start_date - The date from which to start.
days - The working days before or after start_date.
holidays - [optional] A list dates that should be considered non-
work days.
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WEEKDAY Function
The Excel WEEKDAY takes a date and returns a number between 1-7 representing the day of week. By default,
WEEKDAY returns 1 for Sunday and 7 for Saturday. You can use the WEEKDAY function inside other formulas to check
the day of week and react as needed.
Purpose
Get the day of the week as a number
Return value
A number between 0 and 7.
Syntax
=WEEKDAY (serial_number, [return_type])
Arguments
serial_number - The date for which you want to get the day of week.
return_type - [optional] A number 1-3 representing day of week mapping scheme. Default is 1.
NETWORKDAYS Function
The Excel NETWORKDAYS function calculates the number of working days between two dates. NETWORKDAYS auto-
matically excludes weekends (Saturday and Sunday) and can optionally exclude a list of holidays supplied as dates.
Purpose
Get the number of working days between two dates
Return value
A number representing days.
Syntax
=NETWORKDAYS (start_date, end_date, [holidays])
Arguments
start_date - The start date.
end_date - The end date.
holidays - [optional] A list of one or more dates that should be considered non-work days.
EOMONTH Function
The Excel EOMONTH function returns the last day of the month, x months in the past or future. You can use EDATE
to calculate expiration dates, due dates, and other dates that need to land on the last day of a month. Use a positive
value for months to get a date in the future, and a negative value to get a date in the past.
Purpose
Get the last day of the month in future or past months
Return value
A serial number that represents a particular date in Excel.
Syntax
=EOMONTH (start_date, months)
Arguments
start_date - A date that represents the start date in a valid
Excel serial number format.
months - The number of months before or after start_date.
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Whenever you are working with a lot of data, it can be
difficult to compare information in your workbook. Fortu-
nately, Excel includes several tools that make it easier to
view content from different parts of your workbook at the
same time, such as the ability to freeze panes and split
your worksheet.

4.  The rows will be frozen in place, as indicated by the gray line. You can scroll down the worksheet while continuing
to view the frozen rows at the top. In our example, we have scrolled down to row 18.

To freeze columns
1.  Select the column to the right of the column(s) you want to freeze. In our example, we want to freeze column A,
so we will select column B.
2.  Click the View tab on the Ribbon.
3.  Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu
4.  The column will be frozen in place, as indicated by the gray line. You can scroll across the worksheet while
continuing to view the frozen column on the left. In our example, we have scrolled across to column E.

Freezing Panes and View Options

To freeze rows
You may want to see certain rows or columns all the time in your worksheet, especially header cells. By freezing
rows or columns in place, you will be able to scroll through your content while continuing to view the frozen cells.
1.  Select the row below the row(s) you want to freeze. In our example, we want to freeze rows 1 and 2, so we will
select row 3.
2.  Click the View tab on the Ribbon.
3.  Select the Freeze Panes command, then choose Freeze Panes from the drop-down menu.
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*To unfreeze rows or columns, click the Freeze Panes command, then select Unfreeze Panes from the drop-down
menu.

*if you only need to freeze the top row (row 1) or first column (column A) in the worksheet, you can simply select
Freeze Top Row or Freeze First Column from the drop-down menu.

Other view options
If your workbook contains a lot of content, it can some-
times be difficult to compare different sections. Excel in-
cludes additional options to make your workbooks easier
to view and compare. For example, you can choose to open
a new window for your workbook or split a worksheet
into separate panes.
To open a new window for the current workbook
Excel allows you to open multiple windows for a single work-
book at the same time. In our example, we will use this fea-
-ture to compare two different worksheets from the same workbook.
1.  Click the View tab on the Ribbon, then select the New Window command.
2.  A new window for the workbook will appear.
To split a worksheet
Sometimes you may want to compare different sections of the same workbook without creating a new window. The
Split command allows you to divide the worksheet into multiple panes that scroll separately.
1.  Select the cell where you want to split the worksheet. In our example, we will select cell C7.
2.  Click the View tab on the Ribbon, then select the Split command.
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3.  The workbook will be split into different panes. You can scroll
through each pane separately using the scroll bars, allowing you
to compare different sections of the workbook.

Sorting Data
As you add more content to a worksheet, orga-
nizing this information becomes especially im-
portant. You can quickly reorganize a worksheet
by sorting your data. For example, you could or-
ganize a list of contact information by last name.
Content can be sorted alphabetically, numeri-
cally, and in many other ways.
Types of sorting
When sorting data, it is important to first de-
cide if you want the sort to apply to the entire
worksheet or just a cell range.

2.  Sort range sorts the data in a range of cells,
which can be helpful when working with a sheet
that contains several tables. Sorting a range will
not affect other content on the worksheet.
To sort a sheet
In our example, we will sort a T-shirt order form
alphabetically by Last Name (column C).
1.  Select a cell in the column you want to sort
by. In our example, we will select cell C2.

*After creating a split, you can click and drag
the vertical and horizontal dividers to change the
size of each section.
*To remove the split, click the Split command
again.

1.  Sort sheet organizes all of the data in your worksheet by one column. Related information across each row is kept
together when the sort is applied. In the example below, the Contact Name column (column A) has been sorted to
display the names in alphabetical order.
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2.  Select the Data tab on the Ribbon, then click the
Ascending command to sor A to Z.

or the Descending command to Sort Z to A.

In our example, we will click the Ascending command.
3.  The worksheet will be sorted by the selected column. In our
example, the worksheet is now sorted by last name.
To sort a range:
In our example, we will select a separate table in our T-
shirt order form to sort the number of shirts that were or-
dered on different dates.
1.  Select the cell range you want to sort. In our example,
we will select cell range A13:B17.
2.  Select the Data tab on the Ribbon, then click the Sort
command.

3.  The Sort dialog box will appear. Choose the column
you want to sort by. In our example, we want to sort the
data by the number of T-shirt orders, so we will select
Orders.
4.  Decide the sorting order (either ascending or descend-
ing). In our example, we will use Smallest to Largest.
5.  Once you are satisfied with your selection, click OK. 6.  The cell range will be sorted by the

selected column. In our example, the Or-
ders column will be sorted from lowest
to highest. Notice that the other content
in the worksheet was not affected by the
sort.*If your data is not sorting properly,

double-check your cell values to make sure
they are entered into the worksheet cor-
rectly. Even a small typo could cause prob-
lemswhen sorting a large worksheet. In the example on next page, we forgot to include a hyphen in cell A18, causing our

sort to be slightly inaccurate.
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Custom sorting
Sometimes you may find that the default sorting options can not sort data in the order you need. Fortunately, Excel
allows you to create a custom list to define your own sorting order.
To create a custom sort
In our example below, we want to sort the worksheet by T-Shirt Size (column D). A regular sort would organize the
sizes alphabetically, which would be incorrect. Instead, we will create a custom list to sort from smallest to largest.
1.  Select a cell in the column you want to sort by. In our example, we will select cell D2.

2.  Select the Data tab, then click the Sort com-
mand.

3.  The Sort dialog box will appear. Select the column you want to sort by, then choose Custom List... from the Order
field. In our example, we will choose to sort by T-Shirt Size. 4.  The Custom Lists dialog box will appear. Select

NEW LIST from the Custom Lists: box.
5.  Type the items in the desired custom order in
the List entries: box. In our example, we want to
sort our data by T-shirt size from smallest to larg-
est, so we will type Small, Medium, Large, and X-
Large, pressing Enter on the keyboard after each
item.
(see image below)

6.  Click Add to save the new sort order. The new
list will be added to the Custom lists: box. Make
sure the new list is selected, then click OK.
7.  The Custom Lists dialog box will close. Click OK
in the Sort dialog box to perform the custom sort.

8.  The worksheet will be sorted by the custom order. In our example, the worksheet is now organized by T-shirt size
from smallest to largest.
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To sort by cell formatting
You can also choose to sort your worksheet by formatting rather than cell content. This can be especially helpful if
you add color coding to certain cells. In our example below, we will sort by cell color to quickly see which T-shirt
orders have outstanding payments.
1.  Select a cell in the column you want to sort by. In our example, we will select cell E2.

2.  Select the Data tab, then click the Sort com-
mand.
3.  The Sort dialog box will appear. Select the col-
umn you want to sort by, then decide whether you
will sort by Cell Color, Font Color, or Cell Icon from
the Sort On field. In our example, we will sort by
Payment Method (column E) and Cell Color.

4.  Choose a color
to sort by from
the Order field. In
our example, we
will choose light
red.

5.  Click OK. In our example, the worksheet is now sorted by cell color, with the light red cells on top. This allows us
to see which orders still have outstanding payments.
Filtering Data
If your worksheet contains a lot of content,
it can be difficult to find information
quickly. Filters can be used to narrow
down the data in your worksheet, allow-
ing you to view only the information you
need.
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To filter data
In our example, we will apply a filter to an equipment log worksheet to display only the laptops and projectors that
are available for checkout.
1.  In order for filtering to work correctly, your worksheet should include a header row, which is used to identify the
name of each column. In our example, our worksheet is organized into different columns identified by the header
cells in row 1: ID#, Type, Equipment Detail, and so on.
2.  Select the Data tab, then click the Filter command.
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3.  A drop-down arrow   will appear
in the header cell for each column.
4.  Click the drop-down arrow for the
column you want to filter. In our example,
we will filter column B to view only cer-
tain types of equipment.

5.  The Filter menu will appear.
6.  Uncheck the box next to Select All
to quickly deselect all data.

7.  Check the boxes next to the data you
want to filter, then click OK. In this example,
we will check Laptop and Tablet to view
only those types of equipment.
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8.  The data will be filtered, temporarily hiding any content that does not match the criteria. In our example, only
laptops and tablets are visible.

*Filtering options can also be accessed from the Sort & Filter command on the Home tab.
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To apply multiple filters
Filters are cumulative, which means you can apply multiple filters to help narrow down your results. In this ex-
ample, we have already filtered our worksheet to show laptops and projectors, and we would like to narrow it down
further to only show laptops and projectors that were checked out in August.
1.  Click the drop-down arrow for the column you want to filter. In this example, we will add a filter to column D to
view information by date.

2.  The Filter menu will appear.
3.  Check or uncheck the boxes depending on the data you want to filter, then click OK. In our example, we will
uncheck everything except for August.
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4.  The new filter will be applied. In
our example, the worksheet is now fil-
tered to show only laptops and tab-
lets that were checked out in August.

To clear a filter
After applying a filter, you may want to remove—or clear—it from your worksheet so you will be able to filter
content in different ways.
1.  Click the drop-down arrow for the filter you want to clear. In our example, we will clear the filter in column D.

2.  The Filter menu will appear.
3.  Choose Clear Filter From [COLUMN NAME] from the Filter menu. In our example, we will select Clear Filter From
"Checked Out".

4.  The filter will be cleared from the column. The previously hidden data will be displayed.
*To remove all filters from your worksheet,
click the Filter command on the Data tab.
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Advanced filtering
If you need to filter for something specific, basic filtering may not give you enough options. Fortunately, Excel in-
cludes many advanced filtering tools, including search, text, date, and number filtering, which can narrow your
results to help find exactly what you need.
To filter with search
Excel allows you to search for data that contains an exact phrase, number, date, and more. In our example, we will
use this feature to show only Saris brand products in our equipment log.
1.  Select the Data tab, then click the Filter command. A drop-down arrow will appear in the header cell for each
column.
Note: If you have already added filters
to your worksheet, you can skip this
step.
2.  Click the drop-down arrow for the
column you want to filter. In our ex-
ample, we will filter column C.
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3.  The Filter menu will appear. Enter a search term into the search box. Search results will appear automatically
below the Text Filters field as you type. In our example, we will type saris to find all Saris brand equipment.
4.  When you are done, click OK.

5.  The worksheet will be filtered accord-
ing to your search term. In our example, the
worksheet is now filtered to show only Sa-
ris brand equipment.
To use advanced text filters
Advanced text filters can be used to dis-
play more specific information, such as cells
that contain a certain number of characters,
or data that excludes a specific word or
number. In our example, we have already
filtered our worksheet to only show items
with other in the Type column, but we had
like to exclude any item containing the word
case.1.  Select the Data tab, then click the Filter command. A drop-down arrow will appear in the header cell for each

column.
Note: If you have already added filters to your worksheet, you can skip this step.
2.  Click the drop-down arrow for the column you want to filter. In our example, we will filter column C.
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3.  The Filter menu will appear. Hover the mouse over Text Filters, then select the desired text filter from the drop-
down menu. In our example, we will choose Does Not Contain... to view data that does not contain specific text.

4.  The Custom AutoFilter dialog box will
appear. Enter the desired text to the right
of the filter, then click OK. In our example,
we will type case to exclude any items con-
taining this word.

5.  The data will be filtered by the selected
text filter. In our example, our worksheet
now displays items in the Other category
that do not contain the word case.

To use advanced date filters
Advanced date filters can be used to view information from a certain time period, such as last year, next quarter, or
between two dates. In this example, we will use advanced date filters to view only equipment that has been checked
out today.
1.  Select the Data tab, then click the Filter command. A drop-down arrow will appear in the header cell for each
column.
Note: If you have already added filters to your worksheet, you can skip this step.
2.  Click the drop-down arrow for the column you want to filter. In our example, we will filter column D to view only
a certain range of dates.
3.  The Filter menu will appear. Hover the
mouse over Date Filters, then select the
desired date filter from the drop-down
menu. In our example, we will select To-
day to view equipment that has been
checked out on today's date.
4.  The worksheet will be filtered by the
selected date filter. In our example, we
can now see which items have been
checked out today.*If you are working along with the ex-
ample file, your results will be different
from the images above. If you want, you
can change some of the dates so the fil-
ter will give more results.
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Groups and Subtotals
Worksheets with a lot of content can sometimes feel overwhelming and even become difficult to read. Fortunately,
Excel can organize data in groups, allowing you to easily show and hide different sections of your worksheet. You
can also summarize different groups using the Subtotal command and create an outline for your worksheet.
To group rows or columns
1.  Select the rows or columns you want to group. In this example, we will select columns A, B, and C.

2.  Select the Data tab on the Ribbon, then click the Group command.

3.  The selected rows or columns will be grouped. In our example, columns A, B, and C are grouped together.*To ungroup data, select the grouped rows or columns, then click the Ungroup command.

To hide and show groups
1.  To hide a group, click the Hide Detail  button.
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2.  The group will be hidden. To show a hidden group, click the Show Detail button  .

Creating subtotals
The Subtotal command allows you to automatically create groups and use common functions like SUM, COUNT,
and AVERAGE to help summarize your data. For example, the Subtotal command could help to calculate the cost of
office supplies by type from a large inventory order. It will create a hierarchy of groups, known as an outline, to help
organize your worksheet.*Your data must be correctly sorted before using the Subtotal command, so you may want to review our previous
lesson on Sorting Data to learn more.
To create a subtotal
In our example, we will use the Subtotal command with a T-shirt order form to determine how many T-shirts were
ordered in each size (Small, Medium, Large, and X-Large). This will create an outline for our worksheet with a group
for each T-shirt size and then count the total number of shirts in each group.
1.  First, sort your worksheet by the data you want to subtotal. In this example, we will create a subtotal for each T-
shirt size, so our worksheet has been sorted by T-shirt size from smallest to largest.
2.  Select the Data tab, then click the Subtotal command.

3.  The Subtotal dialog box will appear. Click the drop-down arrow for the At
each change in: field to select the column you want to subtotal. In our ex-
ample, we will select T-Shirt Size.
4.  Click the drop-down arrow for the Use function: field to select the func-
tion you want to use. In our example, we will select COUNT to count the
number of shirts ordered in each size.
5.  In the Add subtotal to: field, select the column where you want the calcu-
lated subtotal to appear. In our example, we will select T-Shirt Size.
6.  When you are satisfied with your selections, click OK.
7.  The worksheet will be outlined into groups, and the subtotal will be listed
below each group. In our example, the data is now grouped by T-shirt size,
and the number of shirts ordered in that size appears below each group.
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To view groups by level
When you create subtotals, your worksheet it is
divided into different levels. You can switch be-
tween these levels to quickly control how much
information is displayed in the worksheet by click-
ing the Level buttons

to the left of the worksheet. In our example, we
will switch between all three levels in our out-
line. While this example contains only three lev-
els, Excel can accommodate up to eight.

1.  Click the lowest level to display the least detail. In our example, we will select level 1, which contains only the
grand count, or total number of T-shirts ordered.

2.  Click the next level to expand the detail. In our example, we will select level 2, which contains each subtotal row
but hides all other data from the worksheet.

3.  Click the highest level to view and expand all of your worksheet data. In our example, we will select level 3.

*You can also use the Show and Hide Detail buttons to show and hide the groups within the outline.
To remove subtotals
Sometimes you may not want to keep subtotals in your worksheet, especially if you want to reorganize data in
different ways. If you no longer want to use subtotaling, you will need remove it from your worksheet.
1.  Select the Data tab, then click the Subtotal command. (See image on next page)
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2.  The Subtotal dialog box will appear. Click Remove All.
3.  All worksheet data will be ungrouped, and the subtotals will be removed.*To remove all groups without deleting the subtotals, click the Ungroup
command drop-down arrow, then choose Clear Outline.

Chart
Understanding charts
Excel has several different types of charts, allowing you to choose the one that best fits your data. In order to use
charts effectively, you will need to understand how different charts are used.
To insert a chart
1.  Select the cells you want to chart, including the column titles and row labels. These cells will be the source data
for the chart. In our example, we will select cells A1:F6.

2.  From the Insert tab, click the desired
Chart command. In our example, we
will select Column.

3.  Choose the desired chart type from the drop-down menu.
4.  The selected chart will be inserted in the worksheet.
(See image on next page)
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*If you are not sure which type of chart to use, the
Recommended Charts command will suggest sev-
eral different charts based on the source data.

Chart layout and style
After inserting a chart, there are several things you may want to change about the way your data is displayed. It is
easy to edit a chart's layout and style from the Design tab.
1.  Excel allows you to add chart elements—such as chart titles, legends, and data labels—to make your chart
easier to read. To add a chart element, click the Add Chart Element command on the Design tab, then choose the
desired element from the drop-down menu.

2.  To edit a chart element, like a chart title, simply double-click the place-
holder and begin typing.

3.  If you do not want to add chart elements individually, you can use one of Excel's predefined layouts. Simply click
the Quick Layout command, then choose the desired layout from the drop-down menu.

4.  Excel also includes several different chart styles, which allow you to quickly
modify the look and feel of your chart. To change the chart style, select the de-
sired style from the Chart styles group.
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*You can also use the chart formatting shortcut buttons to quickly add chart elements, change the chart style, and
filter the chart data.

Other chart options
There are many other ways to customize and organize your charts. For example, Excel allows you to rearrange a
chart's data, change the chart type, and even move the chart to a different location in the workbook.
To switch row and column data
Sometimes you may want to change the way charts group your data. For example, in the chart below, the Book Sales
data are grouped by year, with columns for each genre. However, we could switch the rows and columns so the
chart will group the data by genre, with columns for each year. In both cases, the chart contains the same data—it
is just organized differently.
1.  Select the chart you want to modify.
2.  From the Design tab, select the Switch Row/Column command.

3.  The rows and columns will be switched. In our example, the data is now grouped by genre, with columns for each
year.
To change the chart type
If you find that your data is not well suited to a
certain chart, it is easy to switch to a new chart
type. In our example, we will change our chart
from a Column chart to a Line chart.
1.  From the Design tab, click the Change Chart
Type command.
2.  The Change Chart Type dialog box will ap-
pear. Select a new chart type and layout, then
click OK. In our example, we will choose a Line
chart.
3.  The selected chart type will appear. In our example, the line chart makes it easier to see trends in the sales data
over time.
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To move a chart
Whenever you insert a new chart, it will appear as an object on the same worksheet that contains its source data.
Alternatively, you can move the chart to a new worksheet to help keep your data organized.
1.  Select the chart you want to move.
2.  Click the Design tab, then select the Move Chart command.

3.  The Move Chart dialog box will appear. Select the desired location for the chart. In our example, we will choose
to move it to a New sheet, which will create a new worksheet.
4.  Click OK.

5.  The chart will appear in the selected location. In our example, the chart now appears on a new worksheet.
Conditional Formatting
Let us say you have a worksheet with thou-
sands of rows of data. It would be ex-
tremely difficult to see patterns and trends
just from examining the raw information.
Similar to charts and sparklines, condi-
tional formatting provides another way to
visualize data and make worksheets easier
to understand.
Understanding conditional formatting
Conditional formatting allows you to automatically apply formatting—such as colors, icons, and data bars—to one
or more cells based on the cell value. To do this, you will need to create a conditional formatting rule. For example,
a conditional formatting rule might be: If the value is less than $2000, color the cell red. By applying this rule, you
had be able to quickly see which cells contain values less than $2000.
To create a conditional formatting rule
In our example, we have a worksheet containing sales data, and we would like to see which sales people are meeting
their monthly sales goals. The sales goal is $4000 per month, so we will create a conditional formatting rule for any
cells containing a value higher than 4000.
1.  Select the desired cells for the conditional formatting rule.
2.  From the Home tab, click the Conditional Formatting command. A drop-down menu will appear.
3.  Hover the mouse over the desired conditional formatting type, then select the desired rule from the menu that
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appears. In our example, we want to highlight cells that are greater than $4000.
4.  A dialog box will appear. Enter the desired value(s) into the blank
field. In our example, we will enter 4000 as our value.
5. Select a formatting style from the drop-down menu. In our ex-
ample, we will choose Green Fill with Dark Green Text, then click
OK.

6.  The conditional formatting will be applied to the selected cells. In
our example, it is easy to see which salespeople reached the $4000
sales goal for each month.

*You can apply  multiple conditional formatting
rules to a cell range or worksheet, allowing you
to visualize different trends and patterns in your
data.
To remove conditional formatting
1.  Click the Conditional Formatting command. A
drop-down menu will appear.

2.  Hover the mouse over Clear Rules, and choose which rules you want to clear. In our example, we will select Clear
Rules from Entire Sheet to remove all conditional formatting from the worksheet.
3.  The conditional formatting will be removed.*Click Manage Rules to edit or delete individual rules. This is especially useful if you have applied multiple rules to
a worksheet.

Conditional formatting presets
Excel has several predefined styles—or presets—you can use
to quickly apply conditional formatting to your data. They
are grouped into three categories:
Data Bars   are horizontal bars added to each cell, much like
a bar graph.
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Color Scales  change the color of each cell based on its value. Each color scale uses a two- or three-color gradient.
For example, in the Green - Yellow - Red color scale, the highest values are green, the average values are yellow, and
the lowest values are red. Icon Sets  add a specific icon to each cell based on its value.

To use preset conditional formatting
1.  Select the desired cells for the conditional formatting rule.
2.  Click the Conditional Formatting command. A drop-down menu will appear.
3.  Hover the mouse over the desired preset, then choose a preset style from the menu that appears.

4.  The conditional formatting will be applied to the selected cells.
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Pivot Tables
When you have a lot of data, it can sometimes be difficult to analyze all of the information in your worksheet.
PivotTables can help make your worksheets more manageable by summarizing data and allowing you to manipu-
late it in different ways.
Using PivotTables to answer questions
Let us say we wanted to answer the question: What is the amount sold by each salesperson? for the sales data in
the example below. Answering this question could be time consuming and difficult—each salesperson appears on
multiple rows, and we would need to total all of their different orders individually. We could use the Subtotal
command to help find the total for each salesperson, but we would still have a lot of data to work with.

Fortunately, a PivotTable can instantly calculate
and summarize the data in a way that is both
easy to read and manipulate. When we are done,
the PivotTable will look something like this:

Once you have created a PivotTable, you can use it to answer different
questions by rearranging—or pivoting—the data. For example, if we wanted
to answer the question: What is the total amount sold in each month? we
could modify our PivotTable to look like this:
To create a PivotTable
1.  Select the table or cells (including column headers) containing the data you want to use.
2.  From the Insert tab, click the PivotTable command.

3.  The Create PivotTable dialog box will appear. Choose
your settings, then click OK. In our example, we will use
Table1 as our source data and place the PivotTable on a new
worksheet.
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4.  A blank PivotTable and Field List will appear on a new
worksheet.

5.  Once you create a PivotTable, you will need to
decide which fields to add. Each field is simply a
column header from the source data. In the
PivotTable Field List, check the box for each field
you want to add. In our example, we want to
know the total amount sold by each salesperson,
so we Will check the Salesperson and Order
Amount fields.

6.  The selected fields will be added to one of the four areas below the Field List. In our example, the Salesperson
field has been added to the Rows area, while the Order Amount has been added to the Values area. Alternatively,
you can click, hold, and drag a field to the desired area.

7.  The PivotTable will calculate and summarize the selected fields. In
our example, the PivotTable shows the amount sold by each sales-
person.

*Just like with normal spreadsheet data, you can sort the data in a
PivotTable using the Sort & Filter command in the Home tab. You can
also apply any type of number formatting you want. For example, you
may want to change the Number Format to Currency. However, be
aware that some types of formatting may disappear when you modify
the PivotTable.

*If you change any of the data in your source worksheet, the PivotTable will
not update automatically. To manually update it, select the PivotTable and
then go to Analyze  Refresh
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Pivoting data
One of the best things about PivotTables is that they can quickly pivot—or reorganize—data, allowing you to look at
your worksheet data in different ways. Pivoting data can help you answer different questions and even experiment
with the data to discover new trends and patterns.
In our example, we used the PivotTable to answer the question: What is the total amount sold by each salesper-
son? But now we would like to answer a new question: What is the total amount sold in each month? We can do
this by simply changing the field in the Rows area.
To change the row
1.  Click, hold, and drag any existing fields out of the Rows area. The field will disappear.

2.  Drag a new field from the Field
List into the Rows area. In our
example, we will use the Month
field.

3.  The PivotTable will adjust—or pivot—to show the new data. In our example,
it now shows the total order amount for each month.

To add columns
So far, our PivotTable has only shown one column of data
at a time. In order to show multiple columns, you will
need to add a field to the Columns area.
1.  Drag a field from the Field List into the Columns area.
In our example, we will use the Region field.

2.  The PivotTable will include multiple columns. In our example, there
is now a column for each region.

Filters
Sometimes you may want focus on just a certain section of your data. Filters
can be used to narrow down the data in your PivotTable, allowing you to view
only the information you need.
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To add a filter
In our example, we will filter out certain salespeople to determine how they affect the total sales.
1.  Drag a field from the Field List to the Filters area. In this example, we will use the Salesperson field.
2.  The filter will appear above the PivotTable. Click the drop-down arrow, then check the box next to Select
Multiple Items. 3.  Uncheck the box for any items you do not want to in-

clude in the PivotTable. In our example, we will uncheck the
boxes for a few different salespeople, then click OK.

4.  The PivotTable will adjust to reflect the changes.
Slicers
Slicers make filtering data in PivotTables even easier. Slic-
ers are basically just filters, but they are easier and faster
to use, allowing you to instantly pivot your data. If you fre-
quently filter your PivotTables, you may want to consider
using slicers instead of filters.

To add a slicer
1.  Select any cell in the PivotTable.
2.  From the Analyze tab, click the Insert Slicer command.
3.  A dialog box will appear. Select the desired field. In our
example, we will select Salesperson, then click OK.

4.  The slicer will appear next to the PivotTable. Each selected item will be
highlighted in blue. In the example below, the slicer contains a list of all sales-
people, and six of them are currently selected.

5.  Just like filters, only selected items are used in the
PivotTable. When you select or deselect items, the
PivotTable will instantly reflect the changes. Try select-
ing different items to see how they affect the PivotTable.
Press and hold the Ctrl key on your keyboard to select
multiple items from a slicer.
*You can also click the Filter icon in the top-right corner to select all items from the slicer at once.
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PivotCharts
PivotCharts are like regular charts, except they display data from a PivotTable. Just like regular charts, you will be
able to select a chart type, layout, and style that will best represent the data.
To create a PivotChart
In this example, our PivotTable is showing each person's total sales per month. We will use a PivotChart so we can
see the information more clearly.

1.  Select any cell in your PivotTable.
2.  From the Insert tab, click the PivotChart com-
mand.

3.  The Insert Chart dialog box will appear.
Select the desired chart type and layout,
then click OK.

4.  The PivotChart will appear.

*Try using slicers or filters to
change the data that is displayed.
The PivotChart will automatically
adjust to show the new data.
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What-If Analysis
Excel includes many powerful tools to perform complex mathematical calculations, including what-if analysis. This
feature can help you experiment and answer questions with your data, even when the data is incomplete. In this
lesson, you will learn how to use a what-if analysis tool called Goal Seek.
Goal Seek
Whenever you create a formula or function in Excel, you put various parts together to calculate a result. Goal Seek
works in the opposite way: It lets you start with the desired result, and it calculates the input value that will give you
that result. We will use a few examples to show how to use Goal Seek.
To use Goal Seek (example 1)
Let us say you are enrolled in a class. You currently have a grade of 65, and you need at least a 70 to pass the class.
Luckily, you have one final assignment that might be able to raise your average. You can use Goal Seek to find out
what grade you need on the final assignment to pass the class.
In the image below, you can see that the grades on the first four assignments are 58, 70, 72, and 60. Even though we
do not know what the fifth grade will be, we can write a formula—or function—that calculates the final grade. In
this case, each assignment is weighted equally, so all we have to do is average all five grades by typing
=AVERAGE(B2:B6). Once we use Goal Seek, cell B6 will show us the minimum grade we will need to make on that
assignment. 1.  Select the cell whose value you want to change. Whenever you

use Goal Seek, you will need to select a cell that already contains a
formula or function. In our example, we will select cell B7 because
it contains the formula =AVERAGE(B2:B6).

2.  From the Data tab, click the What-If Analysis command,
then select Goal Seek from the drop-down menu.

3.  A dialog box will appear with three fields:
Set cell: This is the cell that will contain the desired result. In our
example, cell B7 is already selected.
To value: This is the desired result. In our example, we will enter
70 because we need to earn at least that to pass the class.
By changing cell: This is the cell where Goal Seek will place its
answer. In our example, we will select cell B6 because we want
to determine the grade we need to earn on the final assignment.
4.  When you are done, click OK.
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5.  The dialog box will tell you if Goal Seek was able to find a solution. Click OK.

6.  The result will appear in the specified cell. In our example, Goal Seek calculated that we will need to score at least
a 90 on the final assignment to earn a passing grade. To use Goal Seek (example 2):

Let us say you are planning an event and
want to invite as many people as you can
without exceeding a budget of $500. We
can use Goal Seek to figure out how
many people to invite. In our example
below, cell B4 contains the formula
=B1+B2*B3 to calculate the total cost of

2.  From the Data tab, click the What-If Analysis
command, then select Goal Seek from the drop-
down menu.
3.  A dialog box will appear with three fields:
Set cell: This is the cell that will contain the de-
sired result. In our example, cell B4 is already se-
lected.
To value: This is the desired result. In our example,
we will enter 500 because we only want to spend
$500.By changing cell: This is the cell where Goal Seek will place its answer. In our example, we will select cell B3 because

we want to know how many guests we can invite without spending more than $500.
was able to find a solution. Click OK.
6.  The result will appear in the specified cell. In our example, Goal
Seek calculated the answer to be approximately 18.62. In this case,
our final answer needs to be a whole number, so we will need to round
the answer up or down. Because rounding up would cause us to ex-
ceed our budget, we will round down to 18 guests.

a room reservation, plus the cost per person.
1.  Select the cell whose value you want to change. In our example, we will select cell B4.

4.  When you are done, click OK.
5.  The dialog box will tell you if Goal Seek
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*As you can see in the example above, some situations will require
the answer to be a whole number. If Goal Seek gives you a decimal,
you will need to round up or down, depending on the situation.

Other types of what-if analysis
For more advanced projects, you may want to consider the other types of what-if analysis: scenarios and data
tables. Instead of starting from the desired result and working backward, like Goal Seek, these options allow you to
test multiple values and see how the results change.
Scenarios   A Scenario is a set of values that Excel saves and can substitute automatically on your worksheet. You can
create and save different groups of values as scenarios and then switch between these scenarios to view the differ-
ent results.
If several people have specific information that you want to use in scenarios, you can collect the information in
separate workbooks, and then merge the scenarios from the different workbooks into one.
After you have all the scenarios you need, you can create a scenario summary report that incorporates information
from all the scenarios.
Scenarios are managed with the Scenario Manager wizard from the What-If Analysis group on the Data tab.
Creating scenarios
Suppose that you want to create a budget but are uncertain of your revenue. By using scenarios, you can define
different possible values for the revenue and then switch between scenarios to perform what-if analyses.
For example, assume that your worst case budget scenario is Gross Revenue of $50,000 and Costs of Goods Sold of
$13,200, leaving $36,800 in Gross Profit. To define this set of values as a scenario, you first enter the values in a
worksheet, as shown in the following illustration

The Changing cells have values that you type in, while the Result cell
contains a formula that is based on the Changing cells (in this illustra-
tion cell B4 has the formula =B2-B3).
You then use the Scenario Manager dialog to save these values as a
scenario. Goto the Data tab > What-If Analysis > Scenario Manager
> Add.

In the Scenario name dialog, name the
scenario Worst Case, and specify that
cells B2 and B3 are the values that
change between scenarios. If you se-
lect the Changing cells on your
worksheet before adding a Scenario,
the Scenario Manager will automati-
cally insert the cells for you, otherwise
you can type them by hand, or use the
cell selection dialog to the right of the
Changing cells dialog box.
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Note: Although this example contains only two changing
cells (B2 and B3), a scenario can contain up to 32 cells.
Protection – You can also protect your scenarios, so in the
Protection section check the options that you want, or
uncheck them if you do not want any protection.
1.  Select Prevent Changes to prevent editing the scenario
when the worksheet is protected.
2.  Select Hidden to prevent displaying the scenario when
the worksheet is protected.
Note: These options apply only to protected worksheets.
For more information about protected worksheets, see Pro-
tect a worksheet
Now suppose that your Best Case budget scenario is Gross
Revenue of $150,000 and Costs of Goods Sold of $26,000,
leaving $124,000 in Gross Profit. To define this set of val-
ues as a scenario, you create another scenario, name it Best
Case, and supply different values for cell B2 (150,000) and
cell B3 (26,000). Because Gross Profit (cell B4) is a formula
- the difference between Revenue (B2) and Costs (B3) -  you
do not change cell B4 for the Best Case scenario.
After you save a scenario, it becomes available in the list of
scenarios that you can use in your what-if analyses. Given
the values in the preceding illustration, if you chose to dis-
play the Best Case scenario, the values in the worksheet
would change to resemble the following illustration:

Merging scenarios
There may be times when you have all the information in
one worksheet or workbook needed to create all the

scenarios that you want to consider. However, you may want to gather scenario information from other sources. For
example, suppose you are trying to create a company budget. You might collect scenarios from different depart-
ments, like Sales, Payroll, Production, Marketing, and Legal, because each of these sources has different information
to use in creating the budget.
You can gather these scenarios into one worksheet by using the Merge command. Each source can supply as many
or as few changing cell values as you want. For example, you might want each department to supply expenditure
projections, but only need revenue projections from a few.
When you choose to merge, the Scenario Manager will load a Merge Scenario wizard, which will list all of the
worksheets in the active workbook, as well as listing any other workbooks you might have open at the time. The
wizard will tell you how many scenarios you have on each source worksheet you select.
When you collect different scenarios from various sources, you should use the same cell structure in each of the
workbooks. For example, Revenue might always go in cell B2 and Expenditures might always go in cell B3. If you use
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different structures for the scenarios from various sources, it can be difficult to merge the results.
Data tables
A data table is a range of cells in which you can change values in some of the cells and come up with different
answers to a problem. A good example of a data table employs the PMT function with different loan amounts and
interest rates to calculate the affordable amount on a home mortgage loan. Experimenting with different values to
observe the corresponding variation in results is a common task in data analysis.
Data table basics
Create either one-variable or two-variable data tables, depending on the number of variables and formulas that you
need to test.

Two-variable data tables
Use a two-variable data table to see how different values
of two variables in one formula will change the results of
that formula. For example, you can use a two-variable data
table to see how different combinations of interest rates
and loan terms will affect a monthly mortgage payment.
In the following illustration, cell C2 contains the payment
formula, =PMT(B3/12,B4,-B5), which uses two input cells,
B3 and B4.
Create a one-variable data table
A one-variable data table contain its input values either in a single column (column-oriented), or across a row (row-
oriented). Any formula in a one-variable data table must refer to only one input cell.
Follow these steps
1.  Type the list of values that you want to substitute in the
input cell—either down one column or across one row. Leave
a few empty rows and columns on either side of the values.
2.  Do one of the following
If the data table is column-oriented (your variable values are
in a column), type the formula in the cell one row above
and one cell to the right of the column of values. This one-
variable data table is column-oriented, and the formula is
contained  in cell D2.

One-variable data tables
Use a one-variable data table if you want to see how dif-
ferent values of one variable in one or more formulas will
change the results of those formulas. For example, you can
use a one-variable data table to see how different interest
rates affect a monthly mortgage payment by using the PMT
function. You enter the variable values in one column or
row, and the outcomes are displayed in an adjacent col-
umn or row.
In the following illustration, cell D2 contains the payment formula, =PMT(B3/12,B4,-B5), which refers to the input
cell B3.
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If you want to examine the effects of various values on other formulas, enter the additional formulas in cells to the
right of the first formula.
If the data table is row-oriented (your variable values are in a row), type the formula in the cell one column to the left
of the first value and one cell below the row of values.
If you want to examine the effects of various values on other formulas, enter the additional formulas in cells below
the first formula.
3.  Select the range of cells that contains the formulas and values that you want to substitute. In the figure above,
this range is C2:D5.
4.  On the Data tab, click What-If Analysis? > Data Table (in the Data Tools group or Forecast group of Excel 2013).
5.  Do one of the following:
If the data table is column-oriented, enter the cell reference for the input cell in the Column input cell field. In the
figure above, the input cell is B3.
If the data table is row-oriented, enter the cell reference for the input cell in the Row input cell field.
Note:  After you create your data table, you might want to change the format of the result cells. In the figure, the
result cells are formatted as currency.
Add a formula to a one-variable data table
Formulas that are used in a one-variable data table must refer to the same input cell.
Follow these steps
1.  Do either of these:
If the data table is column-oriented, enter the new formula in a blank cell to the right of an existing formula in the
top row of the data table.
If the data table is row-oriented, enter the new formula in a empty cell below an existing formula in the first column
of the data table.
2.  Select the range of cells that contains the data table and the new formula.
3.  On the Data tab, click What-If Analysis > Data Table (in the Data Tools group or Forecast group of Excel 2013).
4.  Do either of the following:
If the data table is column-oriented, enter the cell reference for the input cell in the Column input cell box.
If the data table is row-oriented, enter the cell reference for the input cell in the Row input cell box.
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Finalizing and Protecting Workbooks
Before sharing a workbook, you will want to make sure it does not include any spelling errors or information you
want to keep private. Fortunately, Excel includes several tools to help finalize and protect your workbook, including
Spell Check and the Document Inspector.

2.  The Spelling dialog box will appear. For each spelling error in your worksheet, Spell Check will try to offer sugges-
tions for the correct spelling. Choose a suggestion, then click Change to correct the error.

3.  A dialog box will appear after review-
ing all spelling errors. Click OK to close
Spell Check.

*If there are no appropriate suggestions,
you can also enter the correct spelling
manually.

Ignoring spelling "errors"
Spell Check is not always correct. It will sometimes mark certain words as incorrect, even if they are spelled cor-
rectly. This often happens with names, which may not be in the dictionary. You can choose not to change a spelling
"error" using one of three options:
Ignore Once: This will skip the word without changing it.
Ignore All: This will skip the word without changing it and also skip all other instances of the word in your worksheet.
Add: This adds the word to the dictionary so it will never appear as an error again. Make sure the word is spelled
correctly before choosing this option.
Protecting your workbook
By default, anyone with access to your workbook will be able to open, copy, and edit its content unless you protect
it. There are many different ways to protect a workbook, depending on your needs.
To protect your workbook
1.  Click the File tab to access Backstage view.
2.  From the Info pane, click the Protect Workbook command.
3.  In the drop-down menu, choose the option that best suits your needs. In our example, we will select Mark as
Final. Marking your workbook as final is a good way to discourage others from editing the workbook, while the
other options
give you even more control if needed.

To use Spell Check:
1.  From the Review tab, click the Spell-
ing command.
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4.  A dialog box will appear, prompting you to save. Click OK.

5.  Another dialog box will appear. Click OK.

6.  The workbook will be marked as final.
*Marking a workbook as final will not prevent someone from editing it. If you want to prevent people from editing
it, you can use the Restrict Access option instead.

104



Richson Technoserv Opc Pvt. Ltd. MS Excel

Short cut Keys in MS Excel
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1. What is the intersection of a column and a row on a worksheet called?
A. Column B. Value
C. Address D. Cell
2. What type of chart is useful for comparing values over categories?
A. Pie Chart B. Column Chart
C. Line Chart D. Dot Graph
3. Which function in Excel tells how many numeric entries are there?
A. NUM B. COUNT
C. SUM D. CHKNUM
4. A features that displays only the data in column(s) according to specified criteria-
A. Formula B. Sorting
C. Filtering D. Pivot
5. Statistical calculations and preparation of tables and graphs can be done using
A. Adobe Photoshop B. Excel
C. Notepad D. Power Point
6. What type of chart will you use to compare performance of two employees in the year 2016?
A. Column Chart B. Line Chart
C. Pie Chart D. Dot Chart
7. Which one is not a Function in MS Excel?
A. SUM B. AVG
C. MAX D. MIN
8. Functions in MS Excel must begin with-
A. An () sign B. An (=) Equal Sign
C. A (+) Plus Sign D. A > Sign
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9. Which functionin Excel checks whether a condition is true or not ?
A. SUM B. COUNT
C. IF D. AVERAGE
10. In Excel, Columns are labelled as-
A. A, B, C, etc B. 1,2,3 etc
C. A1, A2, etc. D. $A$1, $A$2, etc.
11. The Greater Than sign (>) is an example of _____ operator.
A. Arithmatic B. Logical
C. Conditional D. Greater
12. What type of chart is useful for showing trends or changes over time?
A. Pie Chart B. Column Chart
C. Line Chart D. Dot Graph
13. The process of arranging the items of a column in some sequence or order is known as :
A. Arranging B. Autofill
C. Sorting D. Filtering
14. The ____ feature of MS Excel quickly completes a series of data-
A. Auto Complete B. Auto Fill
C. Fill Handle D. Sorting
15. What type of chart is useful for comparing parts of a whole?
A. Pie Chart B. Column Chart
C. Line Chart D. Dot Graph
16. In Excel, Rows are labelled as ______
A. A, B, C, etc B. 1,2,3 etc
C. A1, A2, etc. D. $A$1, $A$2, etc
17. What do you use to create a chart?
A. Pie Wizard B. Excel Wizard
C. Data Wizard D. Chart Wizard
18. How will you graphically represent expenditure in different departments?
A. Column Chart B. Line Chart
C. Pie Chart D. Dot Chart
19. What type of chart is good for single series of data?
A. Column Chart B. Line Chart
C. Pie Chart D. Cone Chart
20. The basic unit of a worksheet into which you enter data in Excel is called a-
A. cell B. table
C. box D. column
21. How many sheets are there, by default, when we create a new Excel 2013 file ?
A. 1 B. 3
C. 5 D. 10
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22. In Excel, which one denoted a range from B1 through E5
A. B1 - E5 B. B1:E5
C. B1 to E5 D. B1$E5
23. An Excel file is generally called a / an :
A. E-Spreadsheet B.Woorksheet
C. Workbook D.Sheet
24. It is a collection of data that is stored electronically as a series of records in a table.
A. spreadsheet B. presentation
C. database D. MS Word
25. What type of chart will you use to compare performance of sales of two products?
A. Column Chart B. Line Chart
C. Pie Chart D. Both A and B
26. Free online version of MS excel is known as ________
A. Office for the web B. Excel Mobile
C. Word Mobile D. Excel for the web
27. Microsoft Excel was first time launched in ______ by the Microsoft Corporation
A. 1985 B. 1991
C. 1995 D. 1998
28. MS Excel file can NOT be directly exported as -
A. PDF B. TXT
C. PPT D. CSV
29. How cells are named in ms excel?
A. using rename option B. using name box
C. simply double click on sheet name D. simply double click on cell and name it
30. Select correct statement
A. Each Excel workbook can contain multiple worksheets.
B. Each Excel worksheet can contain multiple workbooks.
C. Each Excel workbook can contain multiple spreadsheets.
D. Each Excel worksheet can contain multiple spreadsheets.
31. Another name for a pre-programmed formula in Excel is
(A) Cell (B) Graph
(C) Function (D) Range
32. Which of the following identifies a cell in Excel?
(A) Address (B) Formula
(C) Name (D) Label
33. Which term is used to join the selected cells in to one cell?
(A) Filter (B) Wrap
(C) Pivot (D) Merge
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34.  A(n) ____ is a series of two or more adjacent cells in a column or row or rectangular group of cells.
(A) List (B) Section
(C) Range (D) Area
35. What is the extension of saved file in MS Excel 2013?
(A) .xlsx (B) .xks
(C) .xos (D) .xbs
36. Which command is used to close the window of Excel?
(A) Alt+ F4 (B) Ctrl + W
(C) Ctrl +R (D) Ctrl+ C
37. How many characters can be typed in a single cell in Excel?
(A) 256 (B) 1024
(C) 32000 (D) 65535
38. Tab scrolling button
(A) Allow you to view a different worksheet
(B) Allow you to view additional worksheet rows down
(C) Allow you to view additional worksheet columns to the right
(D) Allow you to view additional sheets tabs
39. The auto calculate feature
(A) Can only add values in a range of cells
(B) Provides a quick way to view the result of an arithmetic operation on a range of cells
(C) Automatically creates formulas and adds them to a worksheet
(D) Both A and C
40. How do you select an entire column in excel?
(A) Select Edit > Select > Column from the menu
(B) Click the column heading letter
(C) Hold down the shift key as you click anywhere in the column
(D) Hold down the Ctrl key as you click anywhere in the column
41. Multiple calculations can be made in a single formula using
(A) Standard formulas (B) Array formula
(C) Complex formulas (D) Smart formula
42. Which of the following is the oldest spreadsheet package?
(A) VisiCalc (B) Lotus 1-2-3
(C) Excel (D) StarCalc
43. Excel worksheet cells work very similarly to what common element of the windows graphical user interface
(A) Option buttons (B) List boxes
(C) Text boxes (D) Combo boxes
44. To copy cell contents using drag and drop press the
(A) End key (B) Shift key
(C) Ctrl key (D) Esc key
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45. Which of the following formulas will Excel Not be able to calculate?
(A) =SUM(Sales)-A3 (B) =SUM(A1:A5)*.5
(C) =SUM(A1:A5)/(10-10) (D) =SUM(A1:A5)-10
46. Data can be arranged in a worksheet in a easy to understand manner using
(A) Auto formatting (B) Applying styles
(C) Changing fonts (D) All of above
47. Which of the following is not a way to complete a cell entry?
(A) Pressing enter
(B) Pressing any arrow key on the keyboard
(C) Clicking the Enter button on the Formula bar
(D) Pressing spacebar
48. Which is used to perform what if analysis?
(A) Solver (B) Goal seek
(C) Scenario Manager (D) All of above
49. When the formula bar is active, you can see
(A) The edit formula button (B) The cancel button
(C) The enter button (D) All of the above
50. To create a formula, you can use:
(A) Values but not cell references
(B) Cell references but not values
(C) Values or cell references although not both at the same time
(D) Value and cell references
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